aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/ppmd
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2018-02-21 17:16:46 +0800
committerehaupt <ehaupt@FreeBSD.org>2018-02-21 17:16:46 +0800
commit715770da67ad0e0af7e946c91e19323fcc3834fb (patch)
treebf934fd157fc525db90d1d73925fd46aca069323 /archivers/ppmd
parent7c17111e790c3a633ddbaebb28c28c220d933efa (diff)
downloadfreebsd-ports-gnome-715770da67ad0e0af7e946c91e19323fcc3834fb.tar.gz
freebsd-ports-gnome-715770da67ad0e0af7e946c91e19323fcc3834fb.tar.zst
freebsd-ports-gnome-715770da67ad0e0af7e946c91e19323fcc3834fb.zip
Fix build on 12.0-CURRENT after upgrading clang, llvm, lld, lldb, compiler-rt
and libc++ to 6.0.0 by falling back to gcc. Notified by: pkg-fallout
Diffstat (limited to 'archivers/ppmd')
-rw-r--r--archivers/ppmd/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/archivers/ppmd/Makefile b/archivers/ppmd/Makefile
index 24cb25725a68..0fceac0bf922 100644
--- a/archivers/ppmd/Makefile
+++ b/archivers/ppmd/Makefile
@@ -14,10 +14,17 @@ PLIST_FILES= bin/ppmd man/man1/ppmd.1.gz
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+# does not compile with clang 6.0.0
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200056
+USE_GCC= yes
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>