aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/py-librtfcomp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /archivers/py-librtfcomp
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'archivers/py-librtfcomp')
-rw-r--r--archivers/py-librtfcomp/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/archivers/py-librtfcomp/Makefile b/archivers/py-librtfcomp/Makefile
index a92c95a4e03f..bc654193ad2a 100644
--- a/archivers/py-librtfcomp/Makefile
+++ b/archivers/py-librtfcomp/Makefile
@@ -14,13 +14,14 @@ COMMENT= Python bindings for library for handling compressed RTF documents
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENCE
-BUILD_DEPENDS= pyrexc:devel/pyrex
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyrex>0:devel/pyrex@${FLAVOR}
LIB_DEPENDS= librtfcomp.so:archivers/librtfcomp
CONFIGURE_ARGS= --enable-python-bindings
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= libtool python:2
+USE_PYTHON= flavors
BUILD_WRKSRC= ${WRKSRC}/python
INSTALL_WRKSRC= ${WRKSRC}/python