aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/rox-archive
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2008-11-09 06:54:17 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2008-11-09 06:54:17 +0800
commitb49e2700ed9f7f231a2159be5debf237cc7fd8c6 (patch)
tree418a3a0716148bc739a4eeb0b35a6c162d6f64db /archivers/rox-archive
parentf60bb300df1260506d605835483206775daaa7ca (diff)
downloadfreebsd-ports-gnome-b49e2700ed9f7f231a2159be5debf237cc7fd8c6.tar.gz
freebsd-ports-gnome-b49e2700ed9f7f231a2159be5debf237cc7fd8c6.tar.zst
freebsd-ports-gnome-b49e2700ed9f7f231a2159be5debf237cc7fd8c6.zip
Use PYTHON_CMD with the -m flag to run compileall (avoid referencing PYTHON_SITELIBDIR).
Diffstat (limited to 'archivers/rox-archive')
-rw-r--r--archivers/rox-archive/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/archivers/rox-archive/Makefile b/archivers/rox-archive/Makefile
index f80e703620b1..0455dec30f92 100644
--- a/archivers/rox-archive/Makefile
+++ b/archivers/rox-archive/Makefile
@@ -25,8 +25,8 @@ post-patch:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -r
do-build:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -m compileall ${WRKSRC}
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/apps