aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/unace/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-04-02 12:19:20 +0800
committersteve <steve@FreeBSD.org>1999-04-02 12:19:20 +0800
commitdd34dd788dbc7a08988378f42ed0466008f9ccbb (patch)
treec58316199d01a9d236572f54e7fa52d5ea593e41 /archivers/unace/Makefile
parentdf88b3abe936ef0ace519b4b5be3039fa9f6e8ac (diff)
downloadfreebsd-ports-gnome-dd34dd788dbc7a08988378f42ed0466008f9ccbb.tar.gz
freebsd-ports-gnome-dd34dd788dbc7a08988378f42ed0466008f9ccbb.tar.zst
freebsd-ports-gnome-dd34dd788dbc7a08988378f42ed0466008f9ccbb.zip
Import of unace version 1.2b.
Extract, view and test ACE archives. PR: 10232 Submitted by: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
Diffstat (limited to 'archivers/unace/Makefile')
-rw-r--r--archivers/unace/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/archivers/unace/Makefile b/archivers/unace/Makefile
new file mode 100644
index 000000000000..72a31448483e
--- /dev/null
+++ b/archivers/unace/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: unace
+# URL: http://members.aol.com/mlemke6413/ace.html
+# Version required: 1.2b
+# Date created: 23 February 1999
+# Whom: Joao Carlos Mendes Luis <jonny@jonny.eng.br>
+#
+# $Id$
+#
+
+DISTNAME= unacepub
+PKGNAME= unace-1.2b
+CATEGORIES= archivers
+MASTER_SITES= http://members.aol.com/mlemke6413/
+EXTRACT_SUFX= .zip
+
+MAINTAINER= jonny@jonny.eng.br
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+FETCH_BEFORE_ARGS= -t
+
+USE_GMAKE= yes
+ALL_TARGET= unace
+MAKEFILE= unix/makefile
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${MKDIR} ${WRKSRC}
+ @unzip -q -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} -d ${WRKSRC}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unace ${PREFIX}/bin
+
+.include <bsd.port.mk>