aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/unzip
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2004-05-27 01:57:30 +0800
committerache <ache@FreeBSD.org>2004-05-27 01:57:30 +0800
commit68bb113203a87ff8adfb61cded4c99241b7c3e19 (patch)
tree9483f426a9d61d4dc5ec4ab340240ff3b42f4fc9 /archivers/unzip
parent8a602fcd4d99707c668c4a422a5d7458689baf35 (diff)
downloadfreebsd-ports-gnome-68bb113203a87ff8adfb61cded4c99241b7c3e19.tar.gz
freebsd-ports-gnome-68bb113203a87ff8adfb61cded4c99241b7c3e19.tar.zst
freebsd-ports-gnome-68bb113203a87ff8adfb61cded4c99241b7c3e19.zip
Upgrade to 5.51
Diffstat (limited to 'archivers/unzip')
-rw-r--r--archivers/unzip/Makefile7
-rw-r--r--archivers/unzip/distinfo4
-rw-r--r--archivers/unzip/files/patch-aa10
-rw-r--r--archivers/unzip/files/patch-ab69
-rw-r--r--archivers/unzip/pkg-descr2
5 files changed, 15 insertions, 77 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 43a7807fca71..98d97c0d354f 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= unzip
-PORTVERSION= 5.50
-PORTREVISION= 2
+PORTVERSION= 5.51
CATEGORIES?= archivers
MASTER_SITES= ftp://ftp.info-zip.org/pub/infozip/src/ \
${MASTER_SITE_TEX_CTAN:S,%SUBDIR%,tools/zip/info-zip/src/,}
-DISTNAME= ${PORTNAME}550
+DISTNAME= ${PORTNAME}551
MAINTAINER?= ache@FreeBSD.org
COMMENT?= List, test and extract compressed files in a ZIP archive
@@ -23,7 +22,7 @@ MAN1= funzip.1 unzip.1 unzipsfx.1 zipgrep.1 zipinfo.1
.if defined(WITH_UNZIP_UNREDUCE)
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unreduce_full.zip
-EXTRACT_ONLY= ${PORTNAME}550.tar.gz
+EXTRACT_ONLY= ${PORTNAME}551.tar.gz
MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK -DUSE_SMITH_CODE"
.endif
diff --git a/archivers/unzip/distinfo b/archivers/unzip/distinfo
index 8c96592a0be2..74ba3caa938d 100644
--- a/archivers/unzip/distinfo
+++ b/archivers/unzip/distinfo
@@ -1,4 +1,4 @@
-MD5 (unzip550.tar.gz) = 798592d62e37f92571184236947122ed
-SIZE (unzip550.tar.gz) = 1068662
+MD5 (unzip551.tar.gz) = 8a25712aac642430d87d21491f7c6bd1
+SIZE (unzip551.tar.gz) = 1112594
MD5 (unreduce_full.zip) = b7cde206d69b403e7551b9b0c25bd345
SIZE (unreduce_full.zip) = 2849
diff --git a/archivers/unzip/files/patch-aa b/archivers/unzip/files/patch-aa
index 4c97f1e8aee3..75300520b4a4 100644
--- a/archivers/unzip/files/patch-aa
+++ b/archivers/unzip/files/patch-aa
@@ -1,5 +1,5 @@
---- unix/Makefile.orig Sun Apr 16 12:27:18 2000
-+++ unix/Makefile Wed May 31 03:30:22 2000
+--- unix/Makefile.orig Mon Mar 1 20:37:24 2004
++++ unix/Makefile Wed May 26 21:43:04 2004
@@ -42,7 +42,7 @@
# such as -DDOSWILD).
@@ -9,14 +9,14 @@
LD = $(CC)# must match, else "unresolved symbol: ___main" is possible)
AS = as
LOC = $(LOCAL_UNZIP)
-@@ -679,8 +679,8 @@
+@@ -727,8 +727,8 @@
# FreeBSD on Intel:
freebsd: unix_make
@echo 'NOTE: use bsd target for non-Intel FreeBSD compiles (if any).'
- $(MAKE) unzips CC=gcc LD=gcc AS=gcc\
-- CF="-O3 -Wall -I. -DASM_CRC -DBSD $(LOC)"\
+- CF="-O3 -Wall -I. -DASM_CRC -DUNIX -DBSD $(LOC)"\
+ $(MAKE) unzips CC=$(CC) LD=$(CC) AS=$(CC)\
-+ CF="-I. -DASM_CRC -DBSD $(LOC)"\
++ CF="-Wall -I. -DASM_CRC -DUNIX -DBSD $(LOC)"\
AF="-Di386 $(AF)" CRC32=crc_gcc
# Generic BSDish Unix gcc. ``The -O3 only works with later versions of gcc;
diff --git a/archivers/unzip/files/patch-ab b/archivers/unzip/files/patch-ab
index 718f5921b89b..50dfd0b5e7a4 100644
--- a/archivers/unzip/files/patch-ab
+++ b/archivers/unzip/files/patch-ab
@@ -1,72 +1,11 @@
---- unix/unix.c.orig Tue Jan 22 01:54:42 2002
-+++ unix/unix.c Tue Jul 29 07:36:54 2003
-@@ -431,6 +431,7 @@
- int killed_ddot = FALSE; /* is set when skipping "../" pathcomp */
- int error = MPN_OK;
- register unsigned workch; /* hold the character being tested */
-+ int ignore_pathcomp;
-
-
- /*---------------------------------------------------------------------------
-@@ -466,33 +467,34 @@
-
- while ((workch = (uch)*cp++) != 0) {
-
-- if (quote) { /* if character quoted, */
-- *pp++ = (char)workch; /* include it literally */
-+ if (quote) { /* if character quoted, include it literally */
-+ /* unless it is a slash */
-+ /* A slash should be converted to an underscore */
-+ *pp++ = (workch == '/' ? '_' : (char)workch);
- quote = FALSE;
- } else
- switch (workch) {
- case '/': /* can assume -j flag not given */
- *pp = '\0';
-- if (((error = checkdir(__G__ pathcomp, APPEND_DIR)) & MPN_MASK)
-- > MPN_INF_TRUNC)
-- return error;
-- pp = pathcomp; /* reset conversion buffer for next piece */
-- lastsemi = (char *)NULL; /* leave directory semi-colons alone */
-- break;
--
-- case '.':
-- if (pp == pathcomp) { /* nothing appended yet... */
-- if (*cp == '/') { /* don't bother appending "./" to */
-- ++cp; /* the path: skip behind the '/' */
-- break;
-- } else if (!uO.ddotflag && *cp == '.' && cp[1] == '/') {
-+ ignore_pathcomp = FALSE;
-+ if (*pathcomp == '.') {
-+ if (pathcomp[1] == '\0') {
-+ /* don't bother appending "./" to the path */
-+ ignore_pathcomp = TRUE;
-+ }
-+ else if (pathcomp[1] == '.' && pathcomp[2] == '\0' && !uO.ddotflag) {
- /* "../" dir traversal detected */
-- cp += 2; /* skip over behind the '/' */
-+ ignore_pathcomp = TRUE;
- killed_ddot = TRUE; /* set "show message" flag */
-- break;
- }
- }
-- *pp++ = '.';
-+ if (!ignore_pathcomp) {
-+ if (((error = checkdir(__G__ pathcomp, APPEND_DIR)) & MPN_MASK)
-+ > MPN_INF_TRUNC)
-+ return error;
-+ }
-+ pp = pathcomp; /* reset conversion buffer for next piece */
-+ lastsemi = (char *)NULL; /* leave directory semi-colons alone */
- break;
-
- case ';': /* VMS version (or DEC-20 attrib?) */
-@@ -519,7 +521,7 @@
+--- unix/unix.c.bak Wed May 26 21:40:00 2004
++++ unix/unix.c Wed May 26 21:40:09 2004
+@@ -533,7 +533,7 @@
default:
/* allow European characters in filenames: */
- if (isprint(workch) || (128 <= workch && workch <= 254))
+ if (isprint(workch) || (128 <= workch && workch <= 255))
*pp++ = (char)workch;
- } /* end switch */
+ } /* end switch */
diff --git a/archivers/unzip/pkg-descr b/archivers/unzip/pkg-descr
index 52363d82b3f8..01f33bf3f25f 100644
--- a/archivers/unzip/pkg-descr
+++ b/archivers/unzip/pkg-descr
@@ -18,4 +18,4 @@ from the specified file instead of from stdin.
Unzipsfx may be used to create self-extracting ZIP archives from previously
created ZIP archives.
-WWW: http://www.ctan.org/tex-archive/tools/zip/info-zip/UnZip.html
+WWW: http://www.mirror.ac.uk/sites/ftp.info-zip.org/pub/infozip/UnZip.html