aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/zip
diff options
context:
space:
mode:
authorsmace <smace@FreeBSD.org>1998-09-23 00:11:07 +0800
committersmace <smace@FreeBSD.org>1998-09-23 00:11:07 +0800
commit2bec6d626e5cde5a03990313f0fe99fb2f764b37 (patch)
tree6bb022abebff509cc4d9f769d40cb5288a222438 /archivers/zip
parent88e0167480428f10f84d183b3428134aeec44a27 (diff)
downloadfreebsd-ports-gnome-2bec6d626e5cde5a03990313f0fe99fb2f764b37.tar.gz
freebsd-ports-gnome-2bec6d626e5cde5a03990313f0fe99fb2f764b37.tar.zst
freebsd-ports-gnome-2bec6d626e5cde5a03990313f0fe99fb2f764b37.zip
Support ELF.
1. Invoke prefixing of external symbols in assembly code functions via __ELF__.
Diffstat (limited to 'archivers/zip')
-rw-r--r--archivers/zip/files/patch-aa31
1 files changed, 31 insertions, 0 deletions
diff --git a/archivers/zip/files/patch-aa b/archivers/zip/files/patch-aa
new file mode 100644
index 000000000000..70b4ab33b3b2
--- /dev/null
+++ b/archivers/zip/files/patch-aa
@@ -0,0 +1,31 @@
+--- unix/Makefile.orig Fri Oct 24 13:38:04 1997
++++ unix/Makefile Thu Sep 17 22:25:33 1998
+@@ -44,6 +44,12 @@
+ LFLAGS1 =
+ LFLAGS2 = -s
+
++.if ${PORTOBJFORMAT} == elf
++ELFDEF = -D__ELF__
++.else
++ELFDEF =
++.endif
++
+ # object file lists
+ OBJZ = zip.o zipfile.o zipup.o fileio.o util.o globals.o crypt.o ttyio.o \
+ unix.o crc32.o crctab.o
+@@ -81,13 +87,13 @@
+ zipup.o: unix/zipup.h
+
+ match.o: match.S
+- $(CPP) match.S > _match.s
++ $(CPP) $(ELFDEF) match.S > _match.s
+ $(AS) _match.s
+ mv _match.o match.o
+ rm -f _match.s
+
+ crc_i386.o: crc_i386.S
+- $(CPP) crc_i386.S > crc_i386.s
++ $(CPP) $(ELFDEF) crc_i386.S > crc_i386.s
+ $(AS) crc_i386.s
+ rm -f crc_i386.s
+