aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-14 14:50:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-14 14:50:59 +0800
commit182432d18127d2513331127d68732ff9ec4ad84e (patch)
treed482208501600e02d671857c3a0bd5660dd8e640 /archivers
parent183664763197aeeeb2c219e9fc728bdb68baa581 (diff)
downloadfreebsd-ports-gnome-182432d18127d2513331127d68732ff9ec4ad84e.tar.gz
freebsd-ports-gnome-182432d18127d2513331127d68732ff9ec4ad84e.tar.zst
freebsd-ports-gnome-182432d18127d2513331127d68732ff9ec4ad84e.zip
- Update MASTER_SITES
- While I'm here: - Cleanup Makefile header - Add LICENSE - Convert to new options framework - Simplify PORTDOCS installation PR: ports/182019 Submitted by: A. J. <freebsd@skysmurf.nl> (maintainer)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/zip/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/archivers/zip/Makefile b/archivers/zip/Makefile
index 9842e20001f7..55edbe2c9797 100644
--- a/archivers/zip/Makefile
+++ b/archivers/zip/Makefile
@@ -1,20 +1,22 @@
-# New ports collection makefile for: Info-ZIP
-# Date created: 22 Dec 1994
-# Whom: Andrey Chernov <ache@FreeBSD.org>
-#
+# Created by: Andrey Chernov <ache@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= zip
PORTVERSION= 3.0
CATEGORIES= archivers
MASTER_SITES= SF/info${PORTNAME}/Zip%203.x%20%28latest%29/${PORTVERSION} \
- ftp://ftp.skysmurf.nl/FreeBSD/distfiles/
+ http://www.skysmurf.nl/comp/FreeBSD/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= freebsd@skysmurf.nl
COMMENT= Create/update ZIP files compatible with PKZIP
+# License is BSD-based, but not identical, so intall with documentation
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= DOCS
+
MAKEFILE= unix/Makefile
ALL_TARGET= generic
@@ -22,18 +24,16 @@ PLIST_FILES= bin/zip bin/zipcloak bin/zipnote bin/zipsplit
MAN1= zip.1 zipcloak.1 zipnote.1 zipsplit.1
PORTDOCS= *
+.include <bsd.port.options.mk>
do-install:
.for p in ${PLIST_FILES:T}
${INSTALL_PROGRAM} ${WRKSRC}/${p} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/${p}.1 ${MANPREFIX}/man/man1
.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-# License is BSD-based, but not identical, so intall with documentation
-. for d in CHANGES LICENSE README* TODO WHATSNEW WHERE
- ${INSTALL_DATA} ${WRKSRC}/${d} ${DOCSDIR}
-. endfor
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES README* TODO WHATSNEW WHERE ${DOCSDIR}
.endif
.include <bsd.port.mk>