aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2019-09-23 00:15:06 +0800
committerJason W. Bacon <jwb@FreeBSD.org>2019-09-23 00:15:06 +0800
commit20d59b725e570b038667f71c952f3ab3bb4d2c8c (patch)
tree59221468f92f74626a35a06e871ec93890ee2ce2 /archivers
parent2b9fa19f044a1db4775d5868a03a0e56959e5fe1 (diff)
downloadfreebsd-ports-gnome-20d59b725e570b038667f71c952f3ab3bb4d2c8c.tar.gz
freebsd-ports-gnome-20d59b725e570b038667f71c952f3ab3bb4d2c8c.tar.zst
freebsd-ports-gnome-20d59b725e570b038667f71c952f3ab3bb4d2c8c.zip
archivers/py-lzstring: LZ-based in-memory string compression
LZ-based, in-memory string compression module, based on the LZ-String javascript module.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-lzstring/Makefile20
-rw-r--r--archivers/py-lzstring/distinfo3
-rw-r--r--archivers/py-lzstring/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 4cb5853525bd..e6b9ad99666d 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -186,6 +186,7 @@
SUBDIR += py-librtfcomp
SUBDIR += py-lz4
SUBDIR += py-lzma
+ SUBDIR += py-lzstring
SUBDIR += py-pyliblzma
SUBDIR += py-python-lhafile
SUBDIR += py-python-lzo
diff --git a/archivers/py-lzstring/Makefile b/archivers/py-lzstring/Makefile
new file mode 100644
index 000000000000..942c471e465f
--- /dev/null
+++ b/archivers/py-lzstring/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= lzstring
+DISTVERSION= 1.0.4
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= LZ-based in-memory string compression
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/archivers/py-lzstring/distinfo b/archivers/py-lzstring/distinfo
new file mode 100644
index 000000000000..f88358f99227
--- /dev/null
+++ b/archivers/py-lzstring/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569116524
+SHA256 (lzstring-1.0.4.tar.gz) = 1afa61e598193fbcc211e0899f09a9679e33f9102bccc37fbfda0b7fef4d9ea2
+SIZE (lzstring-1.0.4.tar.gz) = 4256
diff --git a/archivers/py-lzstring/pkg-descr b/archivers/py-lzstring/pkg-descr
new file mode 100644
index 000000000000..d9906545892f
--- /dev/null
+++ b/archivers/py-lzstring/pkg-descr
@@ -0,0 +1,4 @@
+LZ-based, in-memory string compression module, based on the LZ-String
+javascript module.
+
+WWW: https://pypi.python.org/pypi/lzstring