aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-05 02:45:44 +0800
committerbapt <bapt@FreeBSD.org>2014-01-05 02:45:44 +0800
commit30224679301291b319629b6653e0e1f33f1fb5cc (patch)
treedf53422254a4915ced3a07e53c9b584d508a8c54 /archivers
parentd01525ce802efb67cd1f66b0ad38a6d89ca0aa3c (diff)
downloadfreebsd-ports-gnome-30224679301291b319629b6653e0e1f33f1fb5cc.tar.gz
freebsd-ports-gnome-30224679301291b319629b6653e0e1f33f1fb5cc.tar.zst
freebsd-ports-gnome-30224679301291b319629b6653e0e1f33f1fb5cc.zip
Support stage
Strip binaries Respect DESTDIR Respect CC (this unbreak building on 10+)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/packddir/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/archivers/packddir/Makefile b/archivers/packddir/Makefile
index cad282490012..a7bbffcd6730 100644
--- a/archivers/packddir/Makefile
+++ b/archivers/packddir/Makefile
@@ -13,16 +13,15 @@ COMMENT= These trivial utilities can unpack and create PackdDir archives
WRKSRC= ${WRKDIR}/src
-NO_STAGE= yes
-PLIST_FILES= bin/upackddir
-MAN1= upackddir.1
-
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/upackddir \
+ man/man1/upackddir.1.gz
+MAKE_ARGS= CC=${CC}
post-patch:
- ${REINPLACE_CMD} -e 's|$$(DESTDIR)/usr|${PREFIX}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|$$(DESTDIR)/usr|$$(DESTDIR)${PREFIX}|' ${WRKSRC}/Makefile
post-install:
- ${INSTALL_MAN} ${WRKSRC}/upackddir.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/upackddir.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/upackddir
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>