aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-11-27 00:36:06 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-11-27 00:36:06 +0800
commit489d3b701ec927400742638e19225efdb73325da (patch)
treec1e4fbd0fb1fedf6ffdae4af1204c95848aa6f18 /archivers
parent10a43a166472d15316045af892e5e427a394728a (diff)
downloadfreebsd-ports-gnome-489d3b701ec927400742638e19225efdb73325da.tar.gz
freebsd-ports-gnome-489d3b701ec927400742638e19225efdb73325da.tar.zst
freebsd-ports-gnome-489d3b701ec927400742638e19225efdb73325da.zip
graphics/yacreader: add new port
YACReader is a free cross-platform comic reader with support for multiple comic files and image formats. YACReader comes with YACReaderLibrary an application for browsing and managing your comic collections with various smooth transition effects. https://www.yacreader.com/
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/unarr/Makefile24
-rw-r--r--archivers/unarr/distinfo3
-rw-r--r--archivers/unarr/pkg-descr13
-rw-r--r--archivers/unarr/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index dcd995477103..75cace3e3c85 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -234,6 +234,7 @@
SUBDIR += unalz
SUBDIR += unarchiver
SUBDIR += unarj
+ SUBDIR += unarr
SUBDIR += undms
SUBDIR += unfoo
SUBDIR += unlzx
diff --git a/archivers/unarr/Makefile b/archivers/unarr/Makefile
new file mode 100644
index 000000000000..bb42a858a234
--- /dev/null
+++ b/archivers/unarr/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= unarr
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.1
+CATEGORIES= archivers
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Decompression library for RAR, TAR, ZIP and 7z* archives
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GH_ACCOUNT= selmf
+
+post-patch:
+.if ${/usr/bin/ld:L:tA} != /usr/bin/ld.lld
+ @${REINPLACE_CMD} 's/ -flto//' ${WRKSRC}/CMakeLists.txt
+.endif
+
+.include <bsd.port.mk>
diff --git a/archivers/unarr/distinfo b/archivers/unarr/distinfo
new file mode 100644
index 000000000000..6bec7f40925a
--- /dev/null
+++ b/archivers/unarr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509781725
+SHA256 (selmf-unarr-v1.0.1_GH0.tar.gz) = 0098e3f33182d16c13eb21278696651b170360a9a4d1c0214db4bd7882253223
+SIZE (selmf-unarr-v1.0.1_GH0.tar.gz) = 79492
diff --git a/archivers/unarr/pkg-descr b/archivers/unarr/pkg-descr
new file mode 100644
index 000000000000..53eabbe82600
--- /dev/null
+++ b/archivers/unarr/pkg-descr
@@ -0,0 +1,13 @@
+It was forked from unarr, which originated as a port of the RAR
+extraction features from The Unarchiver project required for
+extracting images from comic book archives. Zeniko wrote unarr as an
+alternative to libarchive which didn't have support for parsing
+filters or solid compression at the time.
+
+While (lib)unarr was started with the intent of providing unarr with a
+proper cmake based build system suitable for packaging and
+cross-platform development, it's focus has now been extended to
+provide code maintenance and to continue the development of unarr,
+which no longer is maintained.
+
+WWW: https://github.com/selmf/unarr
diff --git a/archivers/unarr/pkg-plist b/archivers/unarr/pkg-plist
new file mode 100644
index 000000000000..cf663b82cf49
--- /dev/null
+++ b/archivers/unarr/pkg-plist
@@ -0,0 +1,5 @@
+include/unarr.h
+lib/libunarr.so
+lib/libunarr.so.1
+lib/libunarr.so.1.0.0
+libdata/pkgconfig/libunarr.pc