aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-01-06 00:59:44 +0800
committerDima Panov <fluffy@FreeBSD.org>2021-01-06 00:59:44 +0800
commit575191b6a15aea479469124433aea0d793d4739f (patch)
tree486dde00cac7c5f771922147fe35119d4aac91a7 /archivers
parent10827d48adf554207001b7ab39b4548c28253ffd (diff)
downloadfreebsd-ports-gnome-575191b6a15aea479469124433aea0d793d4739f.tar.gz
freebsd-ports-gnome-575191b6a15aea479469124433aea0d793d4739f.tar.zst
freebsd-ports-gnome-575191b6a15aea479469124433aea0d793d4739f.zip
archivers/libarchive: add mbedTLS support and remove LZO default
PR: 251496 Submitted by: mm Approved by: maintainer (glewis)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libarchive/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 1357a4956c92..a618b32b998e 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libarchive
PORTVERSION= 3.4.3
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= https://libarchive.org/downloads/
@@ -14,13 +15,18 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
-OPTIONS_DEFINE= LZ4 LZO OPENSSL NETTLE ZSTD
-OPTIONS_DEFAULT=LZ4 LZO OPENSSL
+OPTIONS_DEFINE= LZ4 LZO ZSTD
+OPTIONS_DEFAULT=LZ4 OPENSSL
+OPTIONS_RADIO+= CRYPTO
+OPTIONS_RADIO_CRYPTO= OPENSSL MBEDTLS NETTLE
+
+CRYPTO_DESC= Crypto and hashing support
LZ4_DESC= Support lz4 compression via liblz4
LZO_DESC= Support lzo compression via liblzo2
-OPENSSL_DESC= Mtree and xar hashes support through openssl
+MBEDTLS_DESC= Crypto support from mbedTLS
NETTLE_DESC= Crypto support from Nettle
+OPENSSL_DESC= Crypto support from OpenSSL
ZSTD_DESC= Support zstd compression
USES= cpe iconv libtool localbase:ldflags pathfix
@@ -97,6 +103,9 @@ NETTLE_LIB_DEPENDS= libnettle.so:security/nettle
NETTLE_CONFIGURE_WITH= nettle
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= openssl
+OPENSSL_CONFIGURE_OFF= --without-openssl
+MBEDTLS_LIB_DEPENDS= libmbedtls.so:security/mbedtls
+MBEDTLS_CONFIGURE_WITH= mbedtls
.include <bsd.port.pre.mk>