aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 20:21:11 +0800
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 20:21:11 +0800
commit7aca2531e2d785929c4477143e265a8d9b0b516b (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /archivers
parent2a5ef470852066fb4e7c665bc1bb5be0b206d82b (diff)
downloadfreebsd-ports-gnome-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.gz
freebsd-ports-gnome-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.zst
freebsd-ports-gnome-7aca2531e2d785929c4477143e265a8d9b0b516b.zip
Welcome PHP 7.4 RC 1 in the ports-tree.
There are many greater changes including: - New module ffi - Remove interbase module - Remove recode module - Remove wddx module - Many modules changes the build switches - Many modules changes the config format, so patches needed to be recreated Special thanks to tobik and ale for their support. Reviewed by: tobik, ale, joneum Sponsored by: PHP Update Service Differential Revision: https://reviews.freebsd.org/D21349
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile4
-rw-r--r--archivers/php74-bz2/Makefile11
-rw-r--r--archivers/php74-phar/Makefile11
-rw-r--r--archivers/php74-phar/files/patch-config.m441
-rw-r--r--archivers/php74-phar/files/patch-phar.c11
-rw-r--r--archivers/php74-zip/Makefile11
-rw-r--r--archivers/php74-zlib/Makefile11
-rw-r--r--archivers/php74-zlib/files/patch-zlib.c10
8 files changed, 110 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 75fda2fdc82d..4cb5853525bd 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -163,6 +163,10 @@
SUBDIR += php73-phar
SUBDIR += php73-zip
SUBDIR += php73-zlib
+ SUBDIR += php74-bz2
+ SUBDIR += php74-phar
+ SUBDIR += php74-zip
+ SUBDIR += php74-zlib
SUBDIR += pigz
SUBDIR += pixz
SUBDIR += plzip
diff --git a/archivers/php74-bz2/Makefile b/archivers/php74-bz2/Makefile
new file mode 100644
index 000000000000..7dbd67195373
--- /dev/null
+++ b/archivers/php74-bz2/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -bz2
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php74-phar/Makefile b/archivers/php74-phar/Makefile
new file mode 100644
index 000000000000..70d1cedfe793
--- /dev/null
+++ b/archivers/php74-phar/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -phar
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php74-phar/files/patch-config.m4 b/archivers/php74-phar/files/patch-config.m4
new file mode 100644
index 000000000000..1aba3bd9a5a8
--- /dev/null
+++ b/archivers/php74-phar/files/patch-config.m4
@@ -0,0 +1,41 @@
+--- config.m4.orig 2016-06-21 19:56:50 UTC
++++ config.m4
+@@ -4,8 +4,38 @@ dnl config.m4 for extension phar
+ PHP_ARG_ENABLE(phar, for phar archive support,
+ [ --disable-phar Disable phar support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir PHAR: pcre install prefix], no, no)
++
++
+ if test "$PHP_PHAR" != "no"; then
++
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared,, -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1)
++ PHP_HASH=yes
+ AC_MSG_CHECKING([for phar openssl support])
+ if test "$PHP_HASH_SHARED" != "yes"; then
+ if test "$PHP_HASH" != "no"; then
diff --git a/archivers/php74-phar/files/patch-phar.c b/archivers/php74-phar/files/patch-phar.c
new file mode 100644
index 000000000000..e7ae6cb3328d
--- /dev/null
+++ b/archivers/php74-phar/files/patch-phar.c
@@ -0,0 +1,11 @@
+--- phar.c.orig 2016-06-21 19:56:49 UTC
++++ phar.c
+@@ -3589,7 +3589,7 @@ static const zend_module_dep phar_deps[]
+ ZEND_MOD_OPTIONAL("openssl")
+ ZEND_MOD_OPTIONAL("zlib")
+ ZEND_MOD_OPTIONAL("standard")
+-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
++#if defined(HAVE_HASH)
+ ZEND_MOD_REQUIRED("hash")
+ #endif
+ #if HAVE_SPL
diff --git a/archivers/php74-zip/Makefile b/archivers/php74-zip/Makefile
new file mode 100644
index 000000000000..c75656f517dd
--- /dev/null
+++ b/archivers/php74-zip/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -zip
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php74-zlib/Makefile b/archivers/php74-zlib/Makefile
new file mode 100644
index 000000000000..08b6de27fef4
--- /dev/null
+++ b/archivers/php74-zlib/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -zlib
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php74-zlib/files/patch-zlib.c b/archivers/php74-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..be02c50d1df6
--- /dev/null
+++ b/archivers/php74-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2016-06-21 19:57:08 UTC
++++ zlib.c
+@@ -1480,6 +1480,7 @@ static PHP_MSHUTDOWN_FUNCTION(zlib)
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+ if (!ZLIBG(handler_registered)) {
+ ZLIBG(output_compression) = ZLIBG(output_compression_default);