aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-19 09:56:51 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-19 09:56:51 +0800
commit9c62826e7bd20a071f8f21a34bc04d275f33e202 (patch)
treed9f6517c26ab4235621a9a3ea16c72b567e134fb /archivers
parentec78abc0ee4a1ba6387f37e582d7d344558ef6ea (diff)
downloadfreebsd-ports-gnome-9c62826e7bd20a071f8f21a34bc04d275f33e202.tar.gz
freebsd-ports-gnome-9c62826e7bd20a071f8f21a34bc04d275f33e202.tar.zst
freebsd-ports-gnome-9c62826e7bd20a071f8f21a34bc04d275f33e202.zip
Clean up Makefile
- Use BSD_INSTALL_* - Cosmetic change
Diffstat (limited to 'archivers')
-rw-r--r--archivers/zstd/Makefile19
-rw-r--r--archivers/zstd/pkg-plist2
2 files changed, 9 insertions, 12 deletions
diff --git a/archivers/zstd/Makefile b/archivers/zstd/Makefile
index 2a6d861dbdbe..44a14af5d369 100644
--- a/archivers/zstd/Makefile
+++ b/archivers/zstd/Makefile
@@ -12,19 +12,16 @@ COMMENT= Zstandard - Fast real-time compression algorithm
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+ALL_TARGET= default
+MAKE_ARGS= INCLUDEDIR="${PREFIX}/include" LIBDIR="${PREFIX}/lib" MANDIR="${PREFIX}/man/man1"
USES= gmake
-USE_GITHUB= yes
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
GH_ACCOUNT= facebook
+USE_GITHUB= yes
-PLIST_SUB= LIBVER=${PORTVERSION}
-ALL_TARGET= default
-MAKE_ARGS= MANDIR="${PREFIX}/man/man1" \
- LIBDIR="${PREFIX}/lib" \
- INCLUDEDIR="${PREFIX}/include"
-MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
- INSTALL_MAN="${INSTALL_MAN}" \
- INSTALL_DATA="${INSTALL_DATA}" \
- INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
- INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+post-patch:
+ @${REINPLACE_CMD} -e 's|INSTALL_|BSD_&|' ${WRKSRC}/lib/Makefile ${WRKSRC}/programs/Makefile
.include <bsd.port.mk>
diff --git a/archivers/zstd/pkg-plist b/archivers/zstd/pkg-plist
index 15173690184d..ab3e4711b436 100644
--- a/archivers/zstd/pkg-plist
+++ b/archivers/zstd/pkg-plist
@@ -10,7 +10,7 @@ include/zstd_errors.h
lib/libzstd.a
lib/libzstd.so
lib/libzstd.so.1
-lib/libzstd.so.%%LIBVER%%
+lib/libzstd.so.%%PORTVERSION%%
libdata/pkgconfig/libzstd.pc
man/man1/unzstd.1.gz
man/man1/zstd.1.gz