aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-12-24 21:46:01 +0800
committerKai Knoblich <kai@FreeBSD.org>2020-12-24 21:46:01 +0800
commit9cb5898561b302d952fec8e2fac66a945a2c4915 (patch)
tree9274631a296b893d582fb8062e2f256a3a8c8d77 /archivers
parent7d195372928d0063fee4bc1fcf003eae95a2451e (diff)
downloadfreebsd-ports-gnome-9cb5898561b302d952fec8e2fac66a945a2c4915.tar.gz
freebsd-ports-gnome-9cb5898561b302d952fec8e2fac66a945a2c4915.tar.zst
freebsd-ports-gnome-9cb5898561b302d952fec8e2fac66a945a2c4915.zip
Relax hardcoded paths to fix build with Python 3.8.7
Since r558913 Python 3.8 incorporates BPO-42604 [1] which changed the shared libs naming scheme. This means "EXT_SUFFIX" is now derived from SOABI and yields with Python 3.8 to ".cpython-38.so" instead of ".so". The affected ports strip the libaries in the "post-install" target via hardcoded path(s) and the build fails at the end because the new extension is not expected at this place. Remedy the issue by adding wildcards to these paths. This should also prepare the ports for future Python releases, which will use the new shared libs naming scheme. [1] https://bugs.python.org/issue42604 PR: 252057 Reported by: John Kennedy Reviewed by: fluffy, koobs Approved by: koobs (python)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-brotli/Makefile2
-rw-r--r--archivers/py-lzma/Makefile2
-rw-r--r--archivers/py-python-lhafile/Makefile2
-rw-r--r--archivers/py-zstandard/Makefile2
-rw-r--r--archivers/py-zstd/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/archivers/py-brotli/Makefile b/archivers/py-brotli/Makefile
index 9b5430e80215..e66b610c2750 100644
--- a/archivers/py-brotli/Makefile
+++ b/archivers/py-brotli/Makefile
@@ -20,6 +20,6 @@ USE_PYTHON= autoplist concurrent distutils
SHEBANG_FILES= python/bro.py
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_brotli.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/_brotli*.so
.include <bsd.port.mk>
diff --git a/archivers/py-lzma/Makefile b/archivers/py-lzma/Makefile
index bb47b477c6f8..9042121b6379 100644
--- a/archivers/py-lzma/Makefile
+++ b/archivers/py-lzma/Makefile
@@ -31,6 +31,6 @@ post-install-DOCS-on:
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}
post-install:
- @${STRIP_CMD} ${STAGEDIR}/${PYTHONPREFIX_SITELIBDIR}/pylzma.so
+ @${STRIP_CMD} ${STAGEDIR}/${PYTHONPREFIX_SITELIBDIR}/pylzma*.so
.include <bsd.port.mk>
diff --git a/archivers/py-python-lhafile/Makefile b/archivers/py-python-lhafile/Makefile
index ed527158ac4d..7cee606d2113 100644
--- a/archivers/py-python-lhafile/Makefile
+++ b/archivers/py-python-lhafile/Makefile
@@ -18,6 +18,6 @@ USES= python
USE_PYTHON= distutils autoplist
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/lzhlib.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/lzhlib*.so
.include <bsd.port.mk>
diff --git a/archivers/py-zstandard/Makefile b/archivers/py-zstandard/Makefile
index 8874150cb45e..de6ec89d2fb9 100644
--- a/archivers/py-zstandard/Makefile
+++ b/archivers/py-zstandard/Makefile
@@ -22,6 +22,6 @@ USE_PYTHON= distutils autoplist
PYDISTUTILS_BUILDARGS= --system-zstd
post-install:
- @cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} && ${STRIP_CMD} zstd.so _zstd_cffi.so
+ @cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} && ${STRIP_CMD} zstd*.so _zstd_cffi*.so
.include <bsd.port.mk>
diff --git a/archivers/py-zstd/Makefile b/archivers/py-zstd/Makefile
index becfadbbb583..f1f08e5eb3fc 100644
--- a/archivers/py-zstd/Makefile
+++ b/archivers/py-zstd/Makefile
@@ -18,6 +18,6 @@ USE_PYTHON= distutils autoplist
PYDISTUTILS_BUILDARGS= --external
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/zstd.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/zstd*.so
.include <bsd.port.mk>