aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-20 19:39:49 +0800
committerpav <pav@FreeBSD.org>2004-04-20 19:39:49 +0800
commita90466d5a8349b6bd03977a010d50f4c6caafb4d (patch)
tree6c70d34304cd58e54e88a252e39bba9616ceb36b /archivers
parent603f07ea50b7cfd55be63d99fe12a7263c11c39d (diff)
downloadfreebsd-ports-gnome-a90466d5a8349b6bd03977a010d50f4c6caafb4d.tar.gz
freebsd-ports-gnome-a90466d5a8349b6bd03977a010d50f4c6caafb4d.tar.zst
freebsd-ports-gnome-a90466d5a8349b6bd03977a010d50f4c6caafb4d.zip
Add rzip, a compression program, similar in functionality to gzip or bzip2, but
able to take advantage from long distance redundancies in files, which can sometimes allow rzip to produce much better compression ratios than other programs. WWW: http://rzip.samba.org/
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/rzip/Makefile20
-rw-r--r--archivers/rzip/distinfo2
-rw-r--r--archivers/rzip/files/patch-main.c15
-rw-r--r--archivers/rzip/pkg-descr16
5 files changed, 54 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 97ac3276ca5f..98c8444e4bd2 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -60,6 +60,7 @@
SUBDIR += ruby-bz2
SUBDIR += ruby-zip
SUBDIR += rvm
+ SUBDIR += rzip
SUBDIR += sectar
SUBDIR += sharutils
SUBDIR += squsq
diff --git a/archivers/rzip/Makefile b/archivers/rzip/Makefile
new file mode 100644
index 000000000000..4a258300e3a6
--- /dev/null
+++ b/archivers/rzip/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: rzip
+# Date created: 9 April 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= rzip
+PORTVERSION= 2.0
+CATEGORIES= archivers
+MASTER_SITES= http://rzip.samba.org/ftp/rzip/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Compression program similar to gzip or bzip2
+
+GNU_CONFIGURE= yes
+
+MAN1= rzip.1
+PLIST_FILES= bin/rzip
+
+.include <bsd.port.mk>
diff --git a/archivers/rzip/distinfo b/archivers/rzip/distinfo
new file mode 100644
index 000000000000..c54ba107309a
--- /dev/null
+++ b/archivers/rzip/distinfo
@@ -0,0 +1,2 @@
+MD5 (rzip-2.0.tar.gz) = 8a88b445afba919b122a3899d6d26b2a
+SIZE (rzip-2.0.tar.gz) = 42699
diff --git a/archivers/rzip/files/patch-main.c b/archivers/rzip/files/patch-main.c
new file mode 100644
index 000000000000..ba89703ef58c
--- /dev/null
+++ b/archivers/rzip/files/patch-main.c
@@ -0,0 +1,15 @@
+--- main.c.orig Thu Feb 12 01:01:08 2004
++++ main.c Fri Apr 9 18:28:33 2004
+@@ -137,10 +137,8 @@
+ strlen(control->infile) - strlen(control->suffix)) != 0) {
+ fatal("%s: unknown suffix\n", control->infile);
+ }
+-
+- control->outfile = strndup(control->infile,
+- strlen(control->infile) -
+- strlen(control->suffix));
++ control->outfile = malloc(strlen(control->infile) - strlen(control->suffix) + 1);
++ strncpy(control->outfile, control->infile, strlen(control->infile) - strlen(control->suffix));
+ }
+
+ fd_in = open(control->infile,O_RDONLY);
diff --git a/archivers/rzip/pkg-descr b/archivers/rzip/pkg-descr
new file mode 100644
index 000000000000..34e6001139cc
--- /dev/null
+++ b/archivers/rzip/pkg-descr
@@ -0,0 +1,16 @@
+rzip is a compression program, similar in functionality to gzip or bzip2, but
+able to take advantage from long distance redundancies in files, which can
+sometimes allow rzip to produce much better compression ratios than other
+programs.
+
+The principal advantage of rzip is that it has an effective history buffer of
+900 Mbyte. This means it can find matching pieces of the input file over huge
+distances compared to other commonly used compression programs. The gzip
+program by comparison uses a history buffer of 32 kbyte and bzip2 uses a
+history buffer of 900 kbyte. The second advantage of rzip over bzip2 is that it
+is usually faster. This may seem surprising at first given that rzip uses the
+bzip2 library as a backend (for handling the short-range compression), but it
+makes sense when you realise that rzip has usually reduced the data a fair bit
+before handing it to bzip2, so bzip2 has to do less work.
+
+WWW: http://rzip.samba.org/