aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
committerlinimon <linimon@FreeBSD.org>2011-07-21 13:03:02 +0800
commitb52944915a792d1df1b4539b6ffef32bb06c623c (patch)
tree2d2342fe8b657b24efa68b7b0eedf07f0880f0b9 /archivers
parentcf6c4b2a7fb04e6bebe556711940aa746e81c384 (diff)
downloadfreebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.gz
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.tar.zst
freebsd-ports-gnome-b52944915a792d1df1b4539b6ffef32bb06c623c.zip
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Diffstat (limited to 'archivers')
-rw-r--r--archivers/javatar/Makefile2
-rw-r--r--archivers/jzip.org/Makefile2
-rw-r--r--archivers/jzip.org/files/jzip.org.sh.in2
-rw-r--r--archivers/jzlib/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/archivers/javatar/Makefile b/archivers/javatar/Makefile
index e63a6af0e53b..deb89963c9d5 100644
--- a/archivers/javatar/Makefile
+++ b/archivers/javatar/Makefile
@@ -18,7 +18,7 @@ COMMENT= A Java tar archive io package
RUN_DEPENDS= ${JAVALIBDIR}/activation.jar:${PORTSDIR}/java/jaf
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
NO_BUILD= yes
diff --git a/archivers/jzip.org/Makefile b/archivers/jzip.org/Makefile
index d68becd262a8..b6d66a2af13a 100644
--- a/archivers/jzip.org/Makefile
+++ b/archivers/jzip.org/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
PLIST_FILES= %%JAVAJARDIR%%/jzip.org.jar bin/${PORTNAME}
USE_ZIP= yes
USE_JAVA= yes
-JAVA_VERSION= 1.2+
+JAVA_VERSION= 1.5+
WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}.src
SUB_FILES= ${PORTNAME}.sh
diff --git a/archivers/jzip.org/files/jzip.org.sh.in b/archivers/jzip.org/files/jzip.org.sh.in
index 1e1c53658c04..a4fae5d850fc 100644
--- a/archivers/jzip.org/files/jzip.org.sh.in
+++ b/archivers/jzip.org/files/jzip.org.sh.in
@@ -2,4 +2,4 @@
#
# $FreeBSD$
-JAVA_VERSION=1.2+ "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/jzip.org.jar" "$@"
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/jzip.org.jar" "$@"
diff --git a/archivers/jzlib/Makefile b/archivers/jzlib/Makefile
index c34ded824914..a4afbddc7940 100644
--- a/archivers/jzlib/Makefile
+++ b/archivers/jzlib/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A re-implementation of zlib in pure Java
USE_JAVA= yes
-JAVA_VERSION= 1.4+
+JAVA_VERSION= 1.5+
JAR_FILE= ${WRKSRC}/${PORTNAME}.jar