aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-11-12 10:16:58 +0800
committerswills <swills@FreeBSD.org>2014-11-12 10:16:58 +0800
commite46660492838767e6bb23b17d17d5b159e649df5 (patch)
tree637c7759318f9d26110fe0978a91eec2f1a29207 /archivers
parentfd23e82b535e3da1ae4c9e6be54b9dfceb0b8852 (diff)
downloadfreebsd-ports-gnome-e46660492838767e6bb23b17d17d5b159e649df5.tar.gz
freebsd-ports-gnome-e46660492838767e6bb23b17d17d5b159e649df5.tar.zst
freebsd-ports-gnome-e46660492838767e6bb23b17d17d5b159e649df5.zip
Mark broken with Ruby 2.1
With hat: ruby@
Diffstat (limited to 'archivers')
-rw-r--r--archivers/ruby-lha/Makefile6
-rw-r--r--archivers/ruby-zip/Makefile8
2 files changed, 11 insertions, 3 deletions
diff --git a/archivers/ruby-lha/Makefile b/archivers/ruby-lha/Makefile
index 6a37f89e33fa..219ed0071fe6 100644
--- a/archivers/ruby-lha/Makefile
+++ b/archivers/ruby-lha/Makefile
@@ -30,7 +30,9 @@ post-install:
${INSTALL_SCRIPT} ${EXAMPLES:S,^,${WRKSRC}/,} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 2.0
-BROKEN= Does not build with Ruby 2.0
+
+.if ${RUBY_VER} >= 1.9
+BROKEN= Does not build with Ruby 2.0 or Ruby 2.1
.endif
+
.include <bsd.port.post.mk>
diff --git a/archivers/ruby-zip/Makefile b/archivers/ruby-zip/Makefile
index 2c0e4dfee583..63bb1d02d58f 100644
--- a/archivers/ruby-zip/Makefile
+++ b/archivers/ruby-zip/Makefile
@@ -36,4 +36,10 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} == 2.1
+BROKEN= Does not build with Ruby 2.1
+.endif
+
+.include <bsd.port.post.mk>