aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-01-30 19:24:29 +0800
committerkoobs <koobs@FreeBSD.org>2016-01-30 19:24:29 +0800
commitfc4990a4af58edea767dabd5c4df6fb63b9fe12f (patch)
tree050be23ab199506edbdc57afae33f8c5fb19ef65 /archivers
parent989c250774a8b87127368483d3ac23a7ed0b3c83 (diff)
downloadfreebsd-ports-gnome-fc4990a4af58edea767dabd5c4df6fb63b9fe12f.tar.gz
freebsd-ports-gnome-fc4990a4af58edea767dabd5c4df6fb63b9fe12f.tar.zst
freebsd-ports-gnome-fc4990a4af58edea767dabd5c4df6fb63b9fe12f.zip
[NEW] archivers/py-libarchive-c: Python interface to libarchive
A Python interface to libarchive. It uses the standard ctypes module to dynamically load and access the C library. WWW: https://github.com/Changaco/python-libarchive-c Requested by: emaste, bapt (for diffoscope / reproducible builds)
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-libarchive-c/Makefile26
-rw-r--r--archivers/py-libarchive-c/distinfo2
-rw-r--r--archivers/py-libarchive-c/pkg-descr4
4 files changed, 33 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 401a65d535f1..ff50ed179e32 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -163,6 +163,7 @@
SUBDIR += pxz
SUBDIR += py-attic
SUBDIR += py-bz2file
+ SUBDIR += py-libarchive-c
SUBDIR += py-librtfcomp
SUBDIR += py-lz4
SUBDIR += py-lzma
diff --git a/archivers/py-libarchive-c/Makefile b/archivers/py-libarchive-c/Makefile
new file mode 100644
index 000000000000..3d0d977f3958
--- /dev/null
+++ b/archivers/py-libarchive-c/Makefile
@@ -0,0 +1,26 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libarchive-c
+PORTVERSION= 2.2
+CATEGORIES= archivers python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Python interface to libarchive
+
+LICENSE= LGPL20+
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:${PORTSDIR}/devel/py-pytest
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= Changaco
+GH_PROJECT= python-${PORTNAME}
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest
+
+.include <bsd.port.mk>
diff --git a/archivers/py-libarchive-c/distinfo b/archivers/py-libarchive-c/distinfo
new file mode 100644
index 000000000000..51a528fe59d6
--- /dev/null
+++ b/archivers/py-libarchive-c/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Changaco-python-libarchive-c-2.2_GH0.tar.gz) = 1d1e30a26376d6db40a1b5335538f8361451c936569a95b9fb46326ae1765832
+SIZE (Changaco-python-libarchive-c-2.2_GH0.tar.gz) = 40248
diff --git a/archivers/py-libarchive-c/pkg-descr b/archivers/py-libarchive-c/pkg-descr
new file mode 100644
index 000000000000..5f6665593a60
--- /dev/null
+++ b/archivers/py-libarchive-c/pkg-descr
@@ -0,0 +1,4 @@
+A Python interface to libarchive. It uses the standard ctypes module to
+dynamically load and access the C library.
+
+WWW: https://github.com/Changaco/python-libarchive-c