aboutsummaryrefslogtreecommitdiffstats
path: root/astro/celestia
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /astro/celestia
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 93c9d90d6de4..7e3948e2b5c6 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -27,8 +27,8 @@ USE_LUA= 5.0+ # should be optional, but the build fails without it
WANT_GNOME= yes
CXXFLAGS+= -fsigned-char # fix text rendering (see Gentoo bug 316573)
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
UI_LIST= glut gtk gnome kde
CELESTIA_UI?= glut