aboutsummaryrefslogtreecommitdiffstats
path: root/astro/glunarclock/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-11 01:52:02 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-11 01:52:02 +0800
commitca272d475dd86ce4e031d9674cfa7acd3105aaf4 (patch)
tree5320ec06ccdd5423c4efc61b5f90a014171c6157 /astro/glunarclock/Makefile
parent314c7bccd65695f0286d39b75c76f97c54fa00e0 (diff)
downloadfreebsd-ports-gnome-ca272d475dd86ce4e031d9674cfa7acd3105aaf4.tar.gz
freebsd-ports-gnome-ca272d475dd86ce4e031d9674cfa7acd3105aaf4.tar.zst
freebsd-ports-gnome-ca272d475dd86ce4e031d9674cfa7acd3105aaf4.zip
- Add patch missed in the previous commit;
- use USE_REINPLACE while I here.
Diffstat (limited to 'astro/glunarclock/Makefile')
-rw-r--r--astro/glunarclock/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index 40b3b0b659a4..41c4f1f2315e 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= glunarclock
PORTVERSION= 0.24.1
+PORTREVISION= 1
CATEGORIES= astro gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,6 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -27,8 +29,8 @@ pre-configure:
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>