aboutsummaryrefslogtreecommitdiffstats
path: root/astro/google-earth/Makefile
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2006-11-14 20:27:31 +0800
committerflz <flz@FreeBSD.org>2006-11-14 20:27:31 +0800
commitfb552f873f3648b2718e21d217b67c420c20dba7 (patch)
treed47766a0c3cac9ba9c2868576c46dd08e73600a0 /astro/google-earth/Makefile
parentc4829dcb63dd212d4186dc4545b2a9ecd293e465 (diff)
downloadfreebsd-ports-gnome-fb552f873f3648b2718e21d217b67c420c20dba7.tar.gz
freebsd-ports-gnome-fb552f873f3648b2718e21d217b67c420c20dba7.tar.zst
freebsd-ports-gnome-fb552f873f3648b2718e21d217b67c420c20dba7.zip
- Update to 4.0.2414.
- Fix packing list. - Fetch distfile only if it doesn't already exist. PR: ports/104825 Submitted by: Frank W. Josellis <frank@dynamical-systems.org>
Diffstat (limited to 'astro/google-earth/Makefile')
-rw-r--r--astro/google-earth/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 6b486765789d..e689db93312a 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= google-earth
-PORTVERSION= 4.0.2091
+PORTVERSION= 4.0.2414
CATEGORIES= astro deskutils
MASTER_SITES= http://dl.google.com/earth/GE${PORTVERSION:C/\..*//g}/
DISTFILES= ${TARGET_DISTFILE}
@@ -18,8 +18,10 @@ COMMENT= Explore, Search and Discover
BUILD_DEPENDS= unmakeself:${PORTSDIR}/archivers/unmakeself
RUN_DEPENDS= update-mime-database:${PORTSDIR}/misc/shared-mime-info
+# Current version of Google Earth might not be vulnerable anymore.
+# Use NO_IGNORE=yes and DISABLE_VULNERABILITIES=yes if you're using portaudit
+# to bypass the security checks.
FORBIDDEN= Buffer-overflow vulnerability: http://vuxml.FreeBSD.org/5c9a2769-5ade-11db-a5ae-00508d6a62df.html
-BROKEN= Incomplete pkg-plist
RESTRICTED= Not sure about redistribution rights
@@ -49,8 +51,10 @@ RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
.endif
do-fetch:
- @cd ${DISTDIR}; \
- ${FETCH_CMD} ${FETCH_BEFORE_ARGS} -1 ${MASTER_SITES:S|$|${REAL_DISTFILE}|g} ${FETCH_AFTER_ARGS}
+ @if [ ! -f ${DISTDIR}/${TARGET_DISTFILE} ]; then \
+ cd ${DISTDIR}; \
+ ${FETCH_CMD} ${FETCH_BEFORE_ARGS} -1 ${MASTER_SITES:S|$|${REAL_DISTFILE}|g} ${FETCH_AFTER_ARGS}; \
+ fi
do-build:
@${MKDIR} ${WRKSRC}