aboutsummaryrefslogtreecommitdiffstats
path: root/astro/google-earth
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2016-08-29 22:33:43 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2016-08-29 22:33:43 +0800
commit6edc468ef005d1848276ff20b96b30f5e09651fb (patch)
treed62e85256680c5f66e51c9901e796f20b821d0ca /astro/google-earth
parentb08f3e9ddadaa225704407e6ba61a2fff2654631 (diff)
downloadfreebsd-ports-gnome-6edc468ef005d1848276ff20b96b30f5e09651fb.tar.gz
freebsd-ports-gnome-6edc468ef005d1848276ff20b96b30f5e09651fb.tar.zst
freebsd-ports-gnome-6edc468ef005d1848276ff20b96b30f5e09651fb.zip
astro/google-earth: Update to 7.1.5.1557
- Switch to USES=makeself to minimize Makefile - Improve COMMENT and pkg-descr, to clarify exactly what this port provides - Do not set WRKSRC, as the default works just fine - Fix whitespace at the end of LINUX_DRI_DESC (pet portlint) - Install files with COPYTREE_SHARE instead of CP, to ensure permissions are set correctly - Remove redundant -f after ${RM} Changes this release: http://www.gearthblog.com/blog/archives/2015/05/new-version-google-earth-7-1-5.html Reviewed by: adamw (mentor) Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D7673
Diffstat (limited to 'astro/google-earth')
-rw-r--r--astro/google-earth/Makefile49
-rw-r--r--astro/google-earth/distinfo5
-rw-r--r--astro/google-earth/pkg-descr18
3 files changed, 33 insertions, 39 deletions
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 810302aa113c..bf893b2db8b9 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -1,59 +1,44 @@
# $FreeBSD$
PORTNAME= google-earth
-PORTVERSION= 6.0.3.2197
-PORTREVISION= 5
+PORTVERSION= 7.1.5.1557
PORTEPOCH= 3
CATEGORIES= astro deskutils geography
MASTER_SITES= http://dl.google.com/earth/client/advanced/previous/:previous \
http://dl.google.com/earth/client/current/:current
DISTFILES= GoogleEarthLinux.bin:current
DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
-EXTRACT_ONLY= # none
MAINTAINER= ports@FreeBSD.org
-COMMENT= Explore, Search, and Discover
-
-EXTRACT_DEPENDS= unmakeself:archivers/unmakeself
+COMMENT= Virtual globe, map and geographical information program
RESTRICTED= Not really sure about the redistribution terms
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\..*//g}/
-
OPTIONS_DEFAULT= LINUX_DRI
OPTIONS_SINGLE= LIBGL
OPTIONS_SINGLE_LIBGL= LINUX_DRI NVIDIA_GL NVIDIA_GL_340 NVIDIA_GL_304
-LINUX_DRI_DESC= libGL support via Linux DRI libraries
+LINUX_DRI_DESC= libGL support via Linux DRI libraries
NVIDIA_GL_340_DESC= libGL support via nvidia-driver-340
NVIDIA_GL_304_DESC= libGL support via nvidia-driver-304
USE_LINUX= yes
USE_LINUX_APPS= xorglibs curl nss
-USES= perl5 shared-mime-info desktop-file-utils
+USES= desktop-file-utils makeself perl5 shared-mime-info
USE_PERL5= patch build
-
-#SUB_FILES= bin/googleearth
-
-UNMAKESELF= ${LOCALBASE}/bin/unmakeself
+NO_WRKSUBDIR= yes
NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
NVIDIA_GL_340_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver-340
NVIDIA_GL_304_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver-304
LINUX_DRI_USE= LINUX_APPS=dri,libpciaccess
-# Fixed by the first post-patch target line? Also, linprocfs needs to be mounted.
-#BROKEN= seems to crash on >= 9.x/amd64: http://www.freebsd.org/cgi/query-pr.cgi?pr=160422
-
-do-extract:
- @${MKDIR} ${WRKSRC}
- @${CP} ${DISTDIR}/${DIST_SUBDIR}/${_DISTFILES} ${WRKSRC}
- @cd ${WRKSRC} && ${UNMAKESELF} ${_DISTFILES} && ${RM} -f ${_DISTFILES}
- @cd ${WRKSRC} && ${TAR} xf googleearth-data.tar && ${RM} -f googleearth-data.tar
- @cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
+post-extract:
+ @cd ${WRKSRC} && ${TAR} -xf googleearth-data.tar && ${RM} googleearth-data.tar
+ @cd ${WRKSRC} && ${TAR} -xf googleearth-linux-x86.tar && ${RM} googleearth-linux-x86.tar
post-patch:
- @${REINPLACE_CMD} -e '/OS.*=/s|linux|FreeBSD|' ${WRKSRC}/drivers.ini
- @${REINPLACE_CMD} -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
+ @${REINPLACE_CMD} -i "" -e '/OS.*=/s|linux|FreeBSD|' ${WRKSRC}/drivers.ini
+ @${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f ${LINUXBASE}\$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh
@${REINPLACE_CMD} -i "" -e 's|\"\$$SETUP_INSTALLPATH/|\"${WRKSRC}/|' ${WRKSRC}/postinstall.sh
@@ -67,19 +52,23 @@ post-patch-LINUX_DRI-on:
do-build:
@${SETENV} SETUP_INSTALLPATH=${DATADIR} ${WRKSRC}/postinstall.sh
- @cd ${WRKSRC} && ${RM} -rf setup.* preuninstall.sh postinstall.sh \
+ @cd ${WRKSRC} && ${RM} -r setup.* preuninstall.sh postinstall.sh \
bin/googleearth.orig
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}/bin
${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
${INSTALL_DATA} ${WRKSRC}/googleearth-mimetypes.xml \
${STAGEDIR}${PREFIX}/share/mime/packages/
${INSTALL_DATA} ${WRKSRC}/Google-googleearth.desktop \
${STAGEDIR}${PREFIX}/share/applications/googleearth.desktop
- ${CP} -rp ${WRKSRC}/* ${STAGEDIR}${DATADIR}
- ${RM} -f ${STAGEDIR}${DATADIR}/googleearth-mimetypes.xml \
- ${STAGEDIR}${DATADIR}/googleearth.desktop
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/googleearth ${STAGEDIR}${DATADIR}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/googleearth-bin ${STAGEDIR}${DATADIR}/
+ ${RM} ${WRKSRC}/googleearth-mimetypes.xml \
+ ${WRKSRC}/googleearth.desktop \
+ ${WRKSRC}/googleearth-bin \
+ ${WRKSRC}/bin/googleearth
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
${INSTALL_SCRIPT} ${FILESDIR}/browserwrapper \
${STAGEDIR}${DATADIR}/bin/
${LN} -sf ../${DATADIR_REL}/bin/googleearth \
diff --git a/astro/google-earth/distinfo b/astro/google-earth/distinfo
index 396788753ff7..ce1d34ab00c3 100644
--- a/astro/google-earth/distinfo
+++ b/astro/google-earth/distinfo
@@ -1,2 +1,3 @@
-SHA256 (google-earth/6.0.3.2197/GoogleEarthLinux.bin) = 8c1cabb6a196e93224be05bd8a4786087813075f76e1734a17680c30a9ad972d
-SIZE (google-earth/6.0.3.2197/GoogleEarthLinux.bin) = 33688483
+TIMESTAMP = 1472053564
+SHA256 (google-earth/7.1.5.1557/GoogleEarthLinux.bin) = 8c1cabb6a196e93224be05bd8a4786087813075f76e1734a17680c30a9ad972d
+SIZE (google-earth/7.1.5.1557/GoogleEarthLinux.bin) = 33688483
diff --git a/astro/google-earth/pkg-descr b/astro/google-earth/pkg-descr
index cb5380710586..d6bf5a48dd01 100644
--- a/astro/google-earth/pkg-descr
+++ b/astro/google-earth/pkg-descr
@@ -1,9 +1,13 @@
-The idea is simple. It's a globe that sits inside your PC.
-You point and zoom to anyplace on the planet that you want to explore.
-Satellite images and local facts zoom into view.
-Tap into Google search to show local points of interest and facts.
-Zoom to a specific address to check out an apartment or hotel.
-View driving directions and even fly along your route.
-We invite you to try it now.
+Explore the world with Google Earth. View satellite imagery, maps, terrain,
+3D buildings, galaxies far in space, and the deepest depths of the ocean.
+
+Available features include:
+- Explore rich geographical content
+- Zoom from outer space to street level
+- Search for business locations
+- Visualize your GPS tracks and share with others
+- Fly around cities (or the entire world) in 3D
+- Go back in time with historical imagery
+- Dive beneath the surface of the ocean
WWW: http://earth.google.com/