aboutsummaryrefslogtreecommitdiffstats
path: root/astro/gpsman/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2006-05-12 00:45:18 +0800
committervs <vs@FreeBSD.org>2006-05-12 00:45:18 +0800
commit4515f519b866890cb40aee201de04f00c88295a8 (patch)
treed1bb86ff205ac429b1fe34eb79b06a3b60c0d898 /astro/gpsman/Makefile
parent6d1f2f8405c389565c37ffef7952e965e20f3118 (diff)
downloadfreebsd-ports-gnome-4515f519b866890cb40aee201de04f00c88295a8.tar.gz
freebsd-ports-gnome-4515f519b866890cb40aee201de04f00c88295a8.tar.zst
freebsd-ports-gnome-4515f519b866890cb40aee201de04f00c88295a8.zip
Update to 6.3
PR: ports/97120 Submitted by: maintainer
Diffstat (limited to 'astro/gpsman/Makefile')
-rw-r--r--astro/gpsman/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/astro/gpsman/Makefile b/astro/gpsman/Makefile
index e23d11ebbc21..62b4ad0f67ae 100644
--- a/astro/gpsman/Makefile
+++ b/astro/gpsman/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gpsman
-PORTVERSION= 6.2.1
+PORTVERSION= 6.3
CATEGORIES= astro tk84
MASTER_SITES= http://www.ncc.up.pt/gpsman/gpsmanhtml/
MASTER_SITE_SUBDIR= science/cartography
@@ -23,6 +23,10 @@ NO_BUILD= yes
# MAN1= gpsman.1
# MANCOMPRESSED= yes
+post-patch:
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} "s|/dev/ttyS0|${GPSMAN_DEFAULT_PORT}|" \
+ util/exerciser.tcl manual/html/info/l_realtime.doc.txt gpsman.tcl)
+
pre-install:
@${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/gpsman.tcl
@@ -55,3 +59,9 @@ do-install:
.endif
.include <bsd.port.mk>
+
+.if ${OSVERSION} < 600000
+GPSMAN_DEFAULT_PORT?= /dev/cuaa0
+.else
+GPSMAN_DEFAULT_PORT?= /dev/cuad0
+.endif