aboutsummaryrefslogtreecommitdiffstats
path: root/astro/kstars/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-30 03:17:48 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-30 03:17:48 +0800
commit3e00d5587d9f847d9c53b2f796b86c594acb7814 (patch)
tree1e8b5df6fddc10ec7a1b23b273c68c1ead0e7333 /astro/kstars/Makefile
parentbb0e8eac86df52496f958e83b99246f9006bbae2 (diff)
downloadfreebsd-ports-gnome-3e00d5587d9f847d9c53b2f796b86c594acb7814.tar.gz
freebsd-ports-gnome-3e00d5587d9f847d9c53b2f796b86c594acb7814.tar.zst
freebsd-ports-gnome-3e00d5587d9f847d9c53b2f796b86c594acb7814.zip
astro/kstars: update to 3.0.0
Changelog: http://knro.blogspot.com/2018/12/kstars-v300-is-released.html
Diffstat (limited to 'astro/kstars/Makefile')
-rw-r--r--astro/kstars/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 79b52c615e48..549d63915cd0 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= kstars
-DISTVERSION= 2.9.8
-PORTREVISION= 4
+DISTVERSION= 3.0.0
PORTEPOCH= 1
CATEGORIES= astro kde
MASTER_SITES= KDE/stable/${PORTNAME}
@@ -14,20 +13,24 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
+ libqt5keychain.so:security/qtkeychain \
libraw.so:graphics/libraw \
+ libsecret-1.so:security/libsecret \
libwcs.so:astro/wcslib
BUILD_DEPENDS= xplanet:astro/xplanet
RUN_DEPENDS= xplanet:astro/xplanet
-USES= cmake compiler:c++11-lib eigen:3 gettext kde:5 \
- pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lib desktop-file-utils eigen:3 \
+ gettext gnome kde:5 localbase:ldflags pkgconfig qt:5 tar:xz
+USE_GNOME= glib20
USE_KDE= attica auth bookmarks codecs completion config configwidgets\
coreaddons crash dbusaddons doctools ecm guiaddons i18n \
iconthemes init itemviews jobwidgets kio newstuff notifications \
notifyconfig parts plotting service solid texteditor \
widgetsaddons xmlgui
-USE_QT= concurrent core dbus declarative gui multimedia network opengl printsupport \
- sql svg testlib websockets widgets xml \
+USE_QT= concurrent core datavis3d dbus declarative gui multimedia \
+ network opengl printsupport sql svg testlib websockets widgets \
+ xml \
buildtools_build qmake_build
post-patch: