aboutsummaryrefslogtreecommitdiffstats
path: root/astro/osmosis
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2012-09-25 00:25:58 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2012-09-25 00:25:58 +0800
commitfdacbda5d582c4262fc9a80c6da453d314b09c9e (patch)
tree13f5cbbe6542bfbd9c29d5a54beb618122a32dfe /astro/osmosis
parent9baf86b1cbc00fc42fc63ddcfe60ed0048025d9a (diff)
downloadfreebsd-ports-gnome-fdacbda5d582c4262fc9a80c6da453d314b09c9e.tar.gz
freebsd-ports-gnome-fdacbda5d582c4262fc9a80c6da453d314b09c9e.tar.zst
freebsd-ports-gnome-fdacbda5d582c4262fc9a80c6da453d314b09c9e.zip
- Update to 0.41
- Switch to upstream wrapper script - Simplify the port (greately)
Diffstat (limited to 'astro/osmosis')
-rw-r--r--astro/osmosis/Makefile61
-rw-r--r--astro/osmosis/distinfo4
-rw-r--r--astro/osmosis/files/osmosis.in92
-rw-r--r--astro/osmosis/pkg-plist30
4 files changed, 28 insertions, 159 deletions
diff --git a/astro/osmosis/Makefile b/astro/osmosis/Makefile
index 162254143d09..6d3125e58c76 100644
--- a/astro/osmosis/Makefile
+++ b/astro/osmosis/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= osmosis
-PORTVERSION= 0.40.1
+PORTVERSION= 0.41
CATEGORIES= astro java
-MASTER_SITES= http://bretth.dev.openstreetmap.org/osmosis-build/
+MASTER_SITES= http://bretth.dev.openstreetmap.org/osmosis-build/ \
+ http://mirror.amdmi3.ru/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= amdmi3@FreeBSD.org
@@ -16,59 +17,15 @@ COMMENT= Command line Java app for processing OpenStreetMap data
NO_BUILD= yes
-USE_JAVA= YES
+USE_JAVA= yes
JAVA_VERSION= 1.6+
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-SUB_FILES= osmosis
-
-JAVAJARDIR_REL= ${JAVAJARDIR:C,${PREFIX}/?,,}
-JARFILES= aopalliance-1.0.jar \
- commons-codec-1.5.jar \
- commons-compress-1.2.jar \
- commons-dbcp-1.4.jar \
- commons-logging-1.1.1.jar \
- commons-pool-1.5.4.jar \
- jpf-1.5.jar \
- mysql-connector-java-5.1.18.jar \
- osmosis-apidb-${PORTVERSION}.jar \
- osmosis-areafilter-${PORTVERSION}.jar \
- osmosis-core-${PORTVERSION}.jar \
- osmosis-dataset-${PORTVERSION}.jar \
- osmosis-extract-${PORTVERSION}.jar \
- osmosis-hstore-${PORTVERSION}.jar \
- osmosis-pbf-${PORTVERSION}.jar \
- osmosis-pgsimple-${PORTVERSION}.jar \
- osmosis-pgsnapshot-${PORTVERSION}.jar \
- osmosis-replication-${PORTVERSION}.jar \
- osmosis-set-${PORTVERSION}.jar \
- osmosis-tagfilter-${PORTVERSION}.jar \
- osmosis-xml-${PORTVERSION}.jar \
- osmpbf-1.1.1-754a33af.jar \
- plexus-classworlds-2.4.jar \
- postgis-jdbc-1.3.3.jar \
- postgresql-9.0-801.jdbc4.jar \
- protobuf-java-2.4.1.jar \
- spring-aop-3.0.6.RELEASE.jar \
- spring-asm-3.0.6.RELEASE.jar \
- spring-beans-3.0.6.RELEASE.jar \
- spring-context-3.0.6.RELEASE.jar \
- spring-core-3.0.6.RELEASE.jar \
- spring-expression-3.0.6.RELEASE.jar \
- spring-jdbc-3.0.6.RELEASE.jar \
- spring-tx-3.0.6.RELEASE.jar \
- stax2-api-3.1.1.jar \
- woodstox-core-lgpl-4.1.2.jar \
- xercesImpl-2.9.1.jar
-
-CONFFILES= plexus.conf
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(MYAPP_HOME=\).*|\1${DATADIR}|' ${WRKSRC}/bin/osmosis
do-install:
- @${MKDIR} ${DATADIR}/lib/default
- ${INSTALL_DATA} ${JARFILES:S,^,${WRKSRC}/lib/default/,} ${DATADIR}/lib/default
- @${MKDIR} ${DATADIR}/config
- ${INSTALL_DATA} ${CONFFILES:S,^,${WRKSRC}/config/,} ${DATADIR}/config
- ${INSTALL_SCRIPT} ${WRKDIR}/osmosis ${PREFIX}/bin/osmosis
- cd ${WRKSRC} && ${COPYTREE_SHARE} script ${DATADIR}/
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "script config lib" ${DATADIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/osmosis ${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/astro/osmosis/distinfo b/astro/osmosis/distinfo
index 4e5671ddad2d..331132345e6e 100644
--- a/astro/osmosis/distinfo
+++ b/astro/osmosis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (osmosis-0.40.1.tgz) = 3f4e29184341fbe8996f6dcd70d5c8104cab2a3c643ae4ca6d5389fc232a2d00
-SIZE (osmosis-0.40.1.tgz) = 7683042
+SHA256 (osmosis-0.41.tgz) = e88a382883a4c1252243e4e96b7fa274e2c2564572ba22c23a3506f81fee244c
+SIZE (osmosis-0.41.tgz) = 8602122
diff --git a/astro/osmosis/files/osmosis.in b/astro/osmosis/files/osmosis.in
deleted file mode 100644
index 27db1946c6d6..000000000000
--- a/astro/osmosis/files/osmosis.in
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/sh
-
-# Config files can define several variables used throughout this script.
-# JAVACMD - The java command to launch osmosis.
-# JAVACMD_OPTIONS - The options to append to the java command, typically used to modify jvm settings such as max memory.
-# OSMOSIS_OPTIONS - The options to apply to all osmosis invocations, typically used to add plugins or make quiet operation the default.
-
-if [ -f /etc/osmosis ] ; then
- . /etc/osmosis
-fi
-
-if [ -f "$HOME/.osmosis" ] ; then
- . "$HOME/.osmosis"
-fi
-
-if [ -z "$JAVACMD" ] ; then
- # No JAVACMD provided in osmosis config files, therefore default to java
- JAVACMD="%%LOCALBASE%%/bin/java"
-fi
-
-JAVACMD_OPTIONS="-Xmx1024m ${JAVACMD_OPTIONS}"
-JAVA_VERSION="%%JAVA_VERSION%%"
-export JAVA_VERSION
-
-## resolve links - $0 may be a link to application
-PRG="$0"
-
-# if started without absolute path, but from PATH environment
-if [ ! -s "$PRG" ] ; then
- PRG=`which $PRG`
-fi
-
-# need this for relative symlinks
-while [ -h "$PRG" ] ; do
- ls=`ls -ld "$PRG"`
- link=`expr "$ls" : '.*-> \(.*\)$'`
- if expr "$link" : '/.*' > /dev/null; then
- PRG="$link"
- else
- PRG="`dirname "$PRG"`/$link"
- fi
-done
-
-if [ "x$1x" = "xx" ] || echo "$@" | grep -q -e '--help' ; then
-cat <<EOF
-osmosis
-
-Example Usage
-
-Import a planet file into a local PostgreSQL database.
-
-osmosis --read-xml file=~/osm/planbet/planet.osm --write-apidb host="x" database="x" user="x" password="x"
-
-Export a planet file from a local PostgreSQL database.
-
-osmosis --read-apidb host="x" database="x" user="x" password="x" --write-xml file="planet.osm"
-
-Derive a change set between two planet files.
-
-osmosis --read-xml file="planet2.osm" --read-xml file="planet1.osm" --derive-change --write-xml-change file="planetdiff-1-2.osc"
-
-Derive a change set between a planet file and a database.
-
-osmosis --read-mysql host="x" database="x" user="x" password="x" --read-xml file="planet1.osm" --derive-change --write-xml-change file="planetdiff-1-2.osc"
-
-Apply a change set to a planet file.
-
-osmosis --read-xml-change file="planetdiff-1-2.osc" --read-xml file="planet1.osm" --apply-change --write-xml file="planet2.osm"
-
-Sort the contents of a planet file.
-
-osmosis --read-xml file="data.osm" --sort type="TypeThenId" --write-xml file="data-sorted.osm"
-
-The above examples make use of the default pipe connection feature, however a simple read and write planet file command line could be written in two ways. The first example uses default pipe connection, the second explicitly connects the two components using a pipe named "mypipe". The default pipe connection will always work so long as each task is specified in the correct order.
-
-osmosis --read-xml file="planetin.osm" --write-xml file="planetout.osm"
-
-osmosis --read-xml file="planetin.osm" outPipe.0="mypipe" --write-xml file="planetout.osm" inPipe.0="mypipe"
-
-Full usage details are available at: http://wiki.openstreetmap.org/wiki/Osmosis/DetailedUsage
-
-EOF
-exit 1
-fi
-
-# Build up the classpath of required jar files via classworlds launcher.
-CLASSPATH=%%DATADIR%%/lib/default/plexus-classworlds-*.jar
-
-MAINCLASS=org.codehaus.classworlds.Launcher
-EXEC="$JAVACMD $JAVACMD_OPTIONS -cp $CLASSPATH -Dapp.home=%%DATADIR%% -Dclassworlds.conf=%%DATADIR%%/config/plexus.conf $MAINCLASS $OSMOSIS_OPTIONS $@"
-
-exec $EXEC
diff --git a/astro/osmosis/pkg-plist b/astro/osmosis/pkg-plist
index 866fa1427a5e..cecf4323b07d 100644
--- a/astro/osmosis/pkg-plist
+++ b/astro/osmosis/pkg-plist
@@ -8,19 +8,23 @@ bin/osmosis
%%DATADIR%%/lib/default/commons-pool-1.5.4.jar
%%DATADIR%%/lib/default/jpf-1.5.jar
%%DATADIR%%/lib/default/mysql-connector-java-5.1.18.jar
-%%DATADIR%%/lib/default/osmosis-apidb-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-areafilter-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-core-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-dataset-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-extract-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-hstore-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-pbf-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-pgsimple-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-pgsnapshot-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-replication-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-set-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-tagfilter-0.40.1.jar
-%%DATADIR%%/lib/default/osmosis-xml-0.40.1.jar
+%%DATADIR%%/lib/default/netty-3.2.7.Final.jar
+%%DATADIR%%/lib/default/osmosis-apidb-0.41.jar
+%%DATADIR%%/lib/default/osmosis-areafilter-0.41.jar
+%%DATADIR%%/lib/default/osmosis-core-0.41.jar
+%%DATADIR%%/lib/default/osmosis-dataset-0.41.jar
+%%DATADIR%%/lib/default/osmosis-extract-0.41.jar
+%%DATADIR%%/lib/default/osmosis-hstore-0.41.jar
+%%DATADIR%%/lib/default/osmosis-pbf-0.41.jar
+%%DATADIR%%/lib/default/osmosis-pbf2-0.41.jar
+%%DATADIR%%/lib/default/osmosis-pbfmarshall-0.41.jar
+%%DATADIR%%/lib/default/osmosis-pgsimple-0.41.jar
+%%DATADIR%%/lib/default/osmosis-pgsnapshot-0.41.jar
+%%DATADIR%%/lib/default/osmosis-replication-0.41.jar
+%%DATADIR%%/lib/default/osmosis-replication-http-0.41.jar
+%%DATADIR%%/lib/default/osmosis-set-0.41.jar
+%%DATADIR%%/lib/default/osmosis-tagfilter-0.41.jar
+%%DATADIR%%/lib/default/osmosis-xml-0.41.jar
%%DATADIR%%/lib/default/osmpbf-1.1.1-754a33af.jar
%%DATADIR%%/lib/default/plexus-classworlds-2.4.jar
%%DATADIR%%/lib/default/postgis-jdbc-1.3.3.jar