aboutsummaryrefslogtreecommitdiffstats
path: root/astro/pp3
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-31 22:14:55 +0800
committerbapt <bapt@FreeBSD.org>2012-12-31 22:14:55 +0800
commit9453ef769f865d5dd6fa1f5eacff94493ae5fd56 (patch)
treee1a41c07f69b96859806d9a711eb7cf2e56efb93 /astro/pp3
parent0ee43e8cae46267273481f17fb542aaada0beafc (diff)
downloadfreebsd-ports-gnome-9453ef769f865d5dd6fa1f5eacff94493ae5fd56.tar.gz
freebsd-ports-gnome-9453ef769f865d5dd6fa1f5eacff94493ae5fd56.tar.zst
freebsd-ports-gnome-9453ef769f865d5dd6fa1f5eacff94493ae5fd56.zip
Use PORT_OPTIONS for both EXAMPLES and DOCS
Trim headers
Diffstat (limited to 'astro/pp3')
-rw-r--r--astro/pp3/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/astro/pp3/Makefile b/astro/pp3/Makefile
index f9abaec89d86..cda097192437 100644
--- a/astro/pp3/Makefile
+++ b/astro/pp3/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: pp3
-# Date created: Dec 24, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= pp3
PORTVERSION= 1.3.3
@@ -19,6 +14,8 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
USE_BZIP2= yes
+.include <bsd.port.options.mk>
+
do-build:
cd ${WRKSRC} \
&& ${CXX} ${CXXFLAGS} -DPP3DATA=\"${DATADIR}\" pp3.cc -o pp3
@@ -27,12 +24,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pp3 ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.dat ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/WHATSNEW ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif