aboutsummaryrefslogtreecommitdiffstats
path: root/astro/pyweather/Makefile
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2000-01-06 05:16:53 +0800
committerjedgar <jedgar@FreeBSD.org>2000-01-06 05:16:53 +0800
commit445acf6c1dcedc467c99ce6123ba2e83d96c9179 (patch)
tree5ca9241975f170ad7de240be8bfdd94356767fca /astro/pyweather/Makefile
parentb95abd92757da050a7391ccb121c985c891cda81 (diff)
downloadfreebsd-ports-gnome-445acf6c1dcedc467c99ce6123ba2e83d96c9179.tar.gz
freebsd-ports-gnome-445acf6c1dcedc467c99ce6123ba2e83d96c9179.tar.zst
freebsd-ports-gnome-445acf6c1dcedc467c99ce6123ba2e83d96c9179.zip
Python script that downloads weather data and can be cron'd.
PR: 15806 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'astro/pyweather/Makefile')
-rw-r--r--astro/pyweather/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/astro/pyweather/Makefile b/astro/pyweather/Makefile
new file mode 100644
index 000000000000..dd1b2c163825
--- /dev/null
+++ b/astro/pyweather/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pyWeather
+# Version required: 0.1b
+# Date created: 18 Dec 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= pyWeather
+PKGNAME= pyWeather-0.1b
+CATEGORIES= astro python
+MASTER_SITES= http://members.bellatlantic.net/~rasclkng/
+
+MAINTAINER= andrews@technologist.com
+
+RUN_DEPENDS= ${PYTHON}:${PORTSDIR}/lang/python
+
+NO_BUILD= yes
+PYTHON?= ${LOCALBASE}/bin/python
+
+pre-install:
+ @${PERL} -pi -e "s:/usr/bin/python:${PYTHON}:g" ${WRKSRC}/pyWeather.py
+ @${PERL} -pi -e "s:pyWeather.py:pyWeather:g" ${WRKSRC}/pyWeather.py
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/pyWeather.py ${PREFIX}/bin/pyWeather
+
+.include <bsd.port.mk>