aboutsummaryrefslogtreecommitdiffstats
path: root/astro/rmap
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /astro/rmap
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'astro/rmap')
-rw-r--r--astro/rmap/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/astro/rmap/Makefile b/astro/rmap/Makefile
index 3f32d1f7003c..1a8fe01e22b7 100644
--- a/astro/rmap/Makefile
+++ b/astro/rmap/Makefile
@@ -7,21 +7,21 @@
PORTNAME= rmap
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= astro
MASTER_SITES= http://www.reza.net/rmap/
MAINTAINER= trevor@FreeBSD.org
COMMENT= Generates images of the Earth centered at a particular location
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2 \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
MAN1= rmap.1
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>