aboutsummaryrefslogtreecommitdiffstats
path: root/astro/roadmap
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-14 18:39:40 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-14 18:39:40 +0800
commitefe7559fd55549384542230e4c71d57b8d95b2cf (patch)
tree78d95e983455ca585682e1845daeab30a0593cc7 /astro/roadmap
parent885105ce81d1993abd68220d3615513b085c2569 (diff)
downloadfreebsd-ports-gnome-efe7559fd55549384542230e4c71d57b8d95b2cf.tar.gz
freebsd-ports-gnome-efe7559fd55549384542230e4c71d57b8d95b2cf.tar.zst
freebsd-ports-gnome-efe7559fd55549384542230e4c71d57b8d95b2cf.zip
- Fix the build with recent GCC [1]
- Augment MASTER_SITES - Convert pkg-message -> files/pkg-message.in - Mute MKDIRs - Tidy up package description and message (kill EOL spaces, add a fullstop, reformat slightly) - Properly reindent Makefile header Reported by: pointyhat [1]
Diffstat (limited to 'astro/roadmap')
-rw-r--r--astro/roadmap/Makefile21
-rw-r--r--astro/roadmap/files/pkg-message.in (renamed from astro/roadmap/pkg-message)8
-rw-r--r--astro/roadmap/pkg-descr6
3 files changed, 21 insertions, 14 deletions
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index ac91143d68b4..a21182bc1f7c 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: roadmap
-# Date created: 4 November 2002
-# Whom: Nick Esborn <nick@netdot.net>
+# New ports collection makefile for: RoadMap
+# Date created: 4 November 2002
+# Whom: Nick Esborn <nick@netdot.net>
#
# $FreeBSD$
#
@@ -9,7 +9,9 @@ PORTNAME= roadmap
PORTVERSION= 1.0.6
PORTREVISION= 3
CATEGORIES= astro
-MASTER_SITES= http://roadmap.digitalomaha.net/roadmap/
+MASTER_SITES= http://roadmap.digitalomaha.net/roadmap/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.r/rc/:S/./_/g}_src
MAINTAINER= ports@FreeBSD.org
@@ -31,6 +33,11 @@ GUI_BINS= gtkroadmap gtkroadgps
SCRIPTS= rdmdownload rdmgetall rdmgenmaps rdmcompare
DATA= sprites preferences schema
PORTDOCS= AUTHORS BUGS README TODO
+SUB_FILES+= pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e '150s,static ,, ; 423s,static ,,' \
+ ${WRKSRC}/src/roadmap_download.c
do-install:
.for _GUI_BIN in ${GUI_BINS}
@@ -42,18 +49,18 @@ do-install:
.for _SCRIPT in ${SCRIPTS}
${INSTALL_SCRIPT} ${INSTALL_WRKSRC}/${_SCRIPT} ${PREFIX}/bin/${_BIN}
.endfor
- ${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}
.for _DATA in ${DATA}
${INSTALL_DATA} ${INSTALL_WRKSRC}/${_DATA} ${DATADIR}/${_DATA}
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.for _DOC in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${_DOC} ${DOCSDIR}/${_DOC}
.endfor
.endif
post-install:
- @${SED} -e "s|%%DOCSDIR%%|${DOCSDIR}|" ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/astro/roadmap/pkg-message b/astro/roadmap/files/pkg-message.in
index 6babd84eb27b..97e3c9e497ef 100644
--- a/astro/roadmap/pkg-message
+++ b/astro/roadmap/files/pkg-message.in
@@ -6,10 +6,10 @@ navigation.
The instructions for downloading and installing the necessary
TIGER data are located in:
- %%DOCSDIR%%/README
+ %%DOCSDIR%%/README
-Make sure that you either have a program called flite (a voice synthesizer)
-or disable (mute) audio throught the menu. Other voice synthesizer can
-be used, like festival
+Make sure that you either have a program called flite (a voice
+synthesizer) or disable (mute) audio throught the menu. Other
+voice synthesizer can be used, like festival.
------------------------------------------------------------------
diff --git a/astro/roadmap/pkg-descr b/astro/roadmap/pkg-descr
index ff51f574d6fc..12f600bd0cea 100644
--- a/astro/roadmap/pkg-descr
+++ b/astro/roadmap/pkg-descr
@@ -1,16 +1,16 @@
RoadMap is a program for Linux that displays street maps. The maps are
-provided by the US Census Bureau, and thus only cover the US.
+provided by the US Census Bureau, and thus only cover the US.
RoadMap is at an early stage of development. At this time there are no
routing features implemented yet. RoadMap can only display the map around
a specified street address or follow a GPS device (using gpsd). The plan
for the future is to implement some navigation features similar to those
-found in commercial street navigation systems.
+found in commercial street navigation systems.
RoadMap uses a binary file format for representing the maps that is compact
enough to allow the storage of many maps on a Compact Flash or MultiMedia
card. The map of Los Angeles county takes about 10 Mbytes of flash space.
RoadMap comes with a set of tools to convert the US Census bureau data
-into its own map format.
+into its own map format.
WWW: http://roadmap.digitalomaha.net/