aboutsummaryrefslogtreecommitdiffstats
path: root/astro/seti_applet
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 15:10:50 +0800
committerreg <reg@FreeBSD.org>2000-10-05 15:10:50 +0800
commit30fb8569371544b140cbfbe9d8d545a551b7a815 (patch)
treecf43db91e2cefcf20de68716f427d533c59601f6 /astro/seti_applet
parentcea38f8422a3eeac06b3ce4a5828580a5812d2cc (diff)
downloadfreebsd-ports-gnome-30fb8569371544b140cbfbe9d8d545a551b7a815.tar.gz
freebsd-ports-gnome-30fb8569371544b140cbfbe9d8d545a551b7a815.tar.zst
freebsd-ports-gnome-30fb8569371544b140cbfbe9d8d545a551b7a815.zip
Implement USE_GNOME, part 1.
Diffstat (limited to 'astro/seti_applet')
-rw-r--r--astro/seti_applet/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/astro/seti_applet/Makefile b/astro/seti_applet/Makefile
index de0735e999eb..34b99df1c530 100644
--- a/astro/seti_applet/Makefile
+++ b/astro/seti_applet/Makefile
@@ -13,24 +13,23 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
MAINTAINER= th@cis.ibaraki.ac.jp
-LIB_DEPENDS= panel_applet.4:${PORTSDIR}/x11/gnomecore \
- gnome.4:${PORTSDIR}/x11/gnomelibs \
- gtop.1:${PORTSDIR}/devel/libgtop
-RUN_DEPENDS= setiathome:${PORTSDIR}/astro/setiathome \
- gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
+LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
+RUN_DEPENDS= setiathome:${PORTSDIR}/astro/setiathome
USE_X_PREFIX= yes
-
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
+USE_GNOME= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
- ${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${PKGMESSAGE}
+ @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${PKGMESSAGE}
.include <bsd.port.mk>