aboutsummaryrefslogtreecommitdiffstats
path: root/astro/wcslib
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-11-11 01:27:16 +0800
committerrakuco <rakuco@FreeBSD.org>2013-11-11 01:27:16 +0800
commita8fca07d2e2e1e40bed1fb3f790c095af89f2de5 (patch)
tree87a00110bbdf839e0a2d22f4aafea43c82d7b83a /astro/wcslib
parentc1e550c13634ebc960dabb8d885fcf6f4d4662bd (diff)
downloadfreebsd-ports-gnome-a8fca07d2e2e1e40bed1fb3f790c095af89f2de5.tar.gz
freebsd-ports-gnome-a8fca07d2e2e1e40bed1fb3f790c095af89f2de5.tar.zst
freebsd-ports-gnome-a8fca07d2e2e1e40bed1fb3f790c095af89f2de5.zip
- Support staging, which allows us to simplify the Makefile a bit.
- Fix a regression introduced in r297435 (ports/167611) that hardcoded wcslib.pc's installation path and rendered the sed call in the post-patch target useless. This broke automated builds in things like Poudriere. PR: ports/183718 Submitted by: rakuco@ Approved by: Tony Maher <tonymaher@optusnet.com.au> (maintainer)
Diffstat (limited to 'astro/wcslib')
-rw-r--r--astro/wcslib/Makefile14
-rw-r--r--astro/wcslib/files/patch-GNUmakefile6
-rw-r--r--astro/wcslib/pkg-plist1
3 files changed, 9 insertions, 12 deletions
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index c14f905ae510..5bce06b62bc7 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -9,7 +9,6 @@ MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
MAINTAINER= tonymaher@optusnet.com.au
COMMENT= Library for parsing/generating FITS headers
-NO_STAGE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
USES= gmake
@@ -17,7 +16,6 @@ MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= fitshdr.1
# See makedefs.in which describes why you want to set the extra support.
# For most users it will not be required.
@@ -43,15 +41,13 @@ LIB_DEPENDS+= pgplot.5:${PORTSDIR}/graphics/pgplot
.endif
post-patch:
- @${REINPLACE_CMD} -e 's#%%PKGDIR%%#${LOCALBASE}/libdata#g' \
+ @${REINPLACE_CMD} -e 's#%%PKGDIR%%#${STAGEDIR}${PREFIX}/libdata#g' \
${WRKSRC}/GNUmakefile
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES README COPYING COPYING.LESSER wcslib.pdf ${DOCSDIR})
- @${MKDIR} ${DOCSDIR}/html
- (cd ${WRKSRC}/html && ${INSTALL_DATA} * ${DOCSDIR}/html)
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/ && ${INSTALL_DATA} CHANGES README COPYING COPYING.LESSER wcslib.pdf ${STAGEDIR}${DOCSDIR})
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+ (cd ${WRKSRC}/html && ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}/html)
.include <bsd.port.mk>
diff --git a/astro/wcslib/files/patch-GNUmakefile b/astro/wcslib/files/patch-GNUmakefile
index 3ed59254c878..a8e7c2b92dca 100644
--- a/astro/wcslib/files/patch-GNUmakefile
+++ b/astro/wcslib/files/patch-GNUmakefile
@@ -22,11 +22,11 @@
- $(INSTALL) -m 444 html/* $(HTMLDIR)/html
- if [ ! -d "$(LIBDIR)/pkgconfig" ] ; then \
- $(INSTALL) -d -m 2775 $(LIBDIR)/pkgconfig ; \
-+ if [ ! -d "/usr/local/libdata/pkgconfig" ] ; then \
-+ $(INSTALL) -d -m 2775 /usr/local/libdata/pkgconfig ; \
++ if [ ! -d "%%PKGDIR%%/pkgconfig" ] ; then \
++ $(INSTALL) -d -m 2775 %%PKGDIR%%/pkgconfig ; \
fi
- $(INSTALL) -m 444 wcslib.pc $(LIBDIR)/pkgconfig/wcslib.pc
-+ $(INSTALL) -m 444 wcslib.pc /usr/local/libdata/pkgconfig/wcslib.pc
++ $(INSTALL) -m 444 wcslib.pc %%PKGDIR%%/pkgconfig/wcslib.pc
clean cleaner :
for DIR in $(SUBDIRS) doxygen ; do \
diff --git a/astro/wcslib/pkg-plist b/astro/wcslib/pkg-plist
index 1a4e067d63dd..8008ddc7564e 100644
--- a/astro/wcslib/pkg-plist
+++ b/astro/wcslib/pkg-plist
@@ -29,6 +29,7 @@ lib/libwcs.so
lib/libwcs.so.%%VERSION%%
lib/libwcs.so.4
libdata/pkgconfig/wcslib.pc
+man/man1/fitshdr.1.gz
%%PORTDOCS%%%%DOCSDIR%%/html/functions_0x73.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/html/wcshdr_8h-source.html