aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xrmap/files
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-06-19 13:52:35 +0800
committerdaichi <daichi@FreeBSD.org>2003-06-19 13:52:35 +0800
commita72b74e294e096404737a8033cf671e8ca31d7d0 (patch)
tree7e7aff3cfc27df8aa2a97726b8c3d2cc2d071687 /astro/xrmap/files
parent49d18567fa60f66ce4ce1b789f1c9c5e01c20ac4 (diff)
downloadfreebsd-ports-gnome-a72b74e294e096404737a8033cf671e8ca31d7d0.tar.gz
freebsd-ports-gnome-a72b74e294e096404737a8033cf671e8ca31d7d0.tar.zst
freebsd-ports-gnome-a72b74e294e096404737a8033cf671e8ca31d7d0.zip
o update xrmap to version 2.29
o as usual, delete the patch files in the filesdir and replace with the files in this PR o redefine XMKMF in the Makefile because xmkmf -a did not the good thing o add a "do-configure:" in the Makefile PR: 52491 Submitted by: Serge Gagnon <gagnon__s@videotron.ca> (maintainer)
Diffstat (limited to 'astro/xrmap/files')
-rw-r--r--astro/xrmap/files/patch-Imakefile24
-rw-r--r--astro/xrmap/files/patch-editkit-Imakfile55
2 files changed, 56 insertions, 23 deletions
diff --git a/astro/xrmap/files/patch-Imakefile b/astro/xrmap/files/patch-Imakefile
index ac6d441013ea..195ae16611bb 100644
--- a/astro/xrmap/files/patch-Imakefile
+++ b/astro/xrmap/files/patch-Imakefile
@@ -1,5 +1,5 @@
---- Imakefile.orig Sat May 10 09:02:50 2003
-+++ Imakefile Sat May 10 22:00:54 2003
+--- Imakefile.orig Tue May 20 09:15:57 2003
++++ Imakefile Tue May 20 09:26:51 2003
@@ -1,14 +1,15 @@
XCOMM Should install to /usr or /usr/local ??
-DESTDIR=/usr
@@ -42,7 +42,7 @@
#endif
-@@ -62,28 +63,35 @@
+@@ -63,31 +64,37 @@
ComplexProgramTarget(xrmap)
install.man::
@@ -53,7 +53,7 @@
all::
strip xrmap ; ls -al xrmap
- cd editkit ; make emx
+ cd editkit ; xmkmf ; make
install:: install.man
- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)
@@ -67,6 +67,9 @@
cd themes ; rm -f *~
- cp -fR themes $(DESTDIR)$(SHAREDIR)
+ cp -fR themes $(SHAREDIR)
+ cd pixmaps ;
+- cp -fR pixmaps $(DESTDIR)$(SHAREDIR)
++ cp -fR pixmaps $(SHAREDIR)
if [ -d i18n ] ; then cd i18n ; rm -f *~ ; fi
- if [ -d i18n ] ; then cp -fR i18n $(DESTDIR)$(SHAREDIR) ; fi
- $(MKDIRHIER) $(DESTDIR)$(SHAREDIR)/flags
@@ -80,12 +83,13 @@
+ if [ -d picons ] ; then cp -fR picons $(SHAREDIR) ; fi
+ if [ -d pdfmaps ] ; then cp -fR pdfmaps $(SHAREDIR) ; fi
+ if [ -d factbook ] ; then cp -fR factbook $(SHAREDIR) ; fi
-+ if [ -d picons ] ; then cp -fR picons $(SHAREDIR) ; fi
+ $(MKDIRHIER) $(SHAREDIR)/doc
cp -f CHANGES INSTALL LICENSE MAPEDIT README TODO VECTORMAP WARNING \
-- midi_cfg/README.midi $(DESTDIR)$(SHAREDIR)/doc
-- cd examples ; cp -f * $(DESTDIR)$(SHAREDIR)/doc
-+ midi_cfg/README.midi $(SHAREDIR)/doc
-+ cd examples ; cp -f * $(SHAREDIR)/doc
- cd editkit ; make install
+- EXAMPLE.rc midi_cfg/README.midi $(DESTDIR)$(SHAREDIR)/doc
++ EXAMPLE.rc midi_cfg/README.midi $(SHAREDIR)/doc
+ cd rc ; rm -f *~
+- cp -fR rc $(DESTDIR)$(SHAREDIR)
++ cp -fR rc $(SHAREDIR)
+ cd editkit ; xmkmf ; make install
cat WARNING
+
diff --git a/astro/xrmap/files/patch-editkit-Imakfile b/astro/xrmap/files/patch-editkit-Imakfile
index cc0365c0f06b..1f0c23a73ec6 100644
--- a/astro/xrmap/files/patch-editkit-Imakfile
+++ b/astro/xrmap/files/patch-editkit-Imakfile
@@ -1,16 +1,45 @@
---- editkit/Makefile.orig Wed Apr 30 09:24:13 2003
-+++ editkit/Makefile Wed Apr 30 09:26:32 2003
-@@ -12,10 +12,11 @@
- # TWOBUTN paste with button3 click, set selection with button3 drag
- # MINIMAL to remove bak files, /usr/share/edmtx and e**rc
- # TLL for Terry Loveall personal settings
-+PREFIX=/usr/X11R6
+--- editkit/Imakefile.orig Sun May 18 15:41:24 2003
++++ editkit/Imakefile Tue May 20 12:44:02 2003
+@@ -1,14 +1,16 @@
+ XCOMM Should install to /usr or /usr/local ??
+-DESTDIR=/usr
++DESTDIR=
++PREFIX= /usr/X11R6
++INCLUDES= $(PREFIX)/include
+
+ XCOMM Name of man subdirectory of DESTDIR:
+-MANDIR=/X11R6/man/man1
++MANDIR=$(PREFIX)/man/man1
+
+ XCOMM Name of bin subdirectory of DESTDIR: /X11R6/bin or maybe just /bin
+-BINDIR=/X11R6/bin
++BINDIR=$(PREFIX)/bin
+
+ XCOMM Name of share subdirectory of DESTDIR:
+-SHARE_DIR=/share/editkit
+SHARE_DIR=$(PREFIX)/share/editkit
-+INCLUDES=-I$(PREFIX)/include
--SHARE_DIR=/usr/share/editkit
--
--CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHARE_DIR="\"$(SHARE_DIR)\""
-+CFLAGS = -O2 $(INCLUDES) -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHARE_DIR="\"$(SHARE_DIR)\""
+ XCOMM
+ XCOMM Normally -- except for new architectures -- you should be done there.
+@@ -17,7 +19,7 @@
+ XCOMM Compile options:
+ XCOMM
+
+-CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHARE_DIR="\"$(DESTDIR)$(SHARE_DIR)\""
++CFLAGS = -I$(INCLUDES) -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHARE_DIR="\"$(SHARE_DIR)\""
+
+ LOCAL_LIBRARIES=$(XLIB)
+ DEPLIBS= # I don't know what I'm doing, and I hate imake!
+@@ -32,9 +34,9 @@
+
+ install::
+ mkdir -p $(DESTDIR)$(SHARE_DIR)
+- cp -f rc.example $(DESTDIR)$(SHARE_DIR)/rc.common
+- cd $(DESTDIR)$(SHARE_DIR); ln -sf rc.common emxrc
+- cp -f README $(DESTDIR)$(SHARE_DIR)
++ cp -f rc.example $(SHARE_DIR)/rc.common
++ cd $(SHARE_DIR); ln -sf rc.common emxrc
++ cp -f README $(SHARE_DIR)
- #CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DMINIMAL -DTWOBUTN -DVERTCURS -DTLL
+ clean::
+ rm -f *~