aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-14 16:11:57 +0800
committervs <vs@FreeBSD.org>2005-10-14 16:11:57 +0800
commit05181b854060a744fc50ecba448990916360be1f (patch)
treee2752e64fc8daa33b532ceb94e337c187bdb82af /astro
parentee85d37e065571e3b559d89b50870c281d6eea29 (diff)
downloadfreebsd-ports-gnome-05181b854060a744fc50ecba448990916360be1f.tar.gz
freebsd-ports-gnome-05181b854060a744fc50ecba448990916360be1f.tar.zst
freebsd-ports-gnome-05181b854060a744fc50ecba448990916360be1f.zip
Use MAKE_ARGS
Approved by: maintainers
Diffstat (limited to 'astro')
-rw-r--r--astro/accrete/Makefile8
-rw-r--r--astro/accrete/files/patch-Makefile25
-rw-r--r--astro/phoon/Makefile4
-rw-r--r--astro/phoon/files/patch-Makefile33
4 files changed, 6 insertions, 64 deletions
diff --git a/astro/accrete/Makefile b/astro/accrete/Makefile
index 7b19cc331b9b..52e24d423219 100644
--- a/astro/accrete/Makefile
+++ b/astro/accrete/Makefile
@@ -13,12 +13,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= chuck@pkix.net
COMMENT= Accrete is a physical simulation of solar system planet formation
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX=${PREFIX} \
+ CDEBUG="" COPT=""
PLIST_FILES= bin/accrete
-USE_REINPLACE= yes
-
-post-patch:
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
- s|%%CC%%|${CC}|g ; \
- s|%%CFLAGS%%|${CFLAGS}|g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/astro/accrete/files/patch-Makefile b/astro/accrete/files/patch-Makefile
deleted file mode 100644
index c39315cbe123..000000000000
--- a/astro/accrete/files/patch-Makefile
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.org Tue Jul 29 14:53:03 2003
-+++ Makefile Tue Jul 29 14:53:37 2003
-@@ -7,17 +7,17 @@
- INSTALL = /usr/bin/install -s
-
- # installation prefix
--PREFIX = /usr/local
-+PREFIX = %%PREFIX%%
-
- # Compiler flags
--CC ?= cc
--CDEBUG = -g -O -Wall
--COPT = -O3 -ffast-math
-+CC = %%CC%%
-+CDEBUG =
-+COPT =
-
- # Enable this to greatly increase the verbosity of the output
- # DEFS = -DDEBUG -DVERBOSE
-
--CFLAGS ?= -pipe $(CDEBUG) $(DEFS)
-+CFLAGS = %%CFLAGS%%
-
- # Any libraries that are needed...
- LDFLAGS = -lm
diff --git a/astro/phoon/Makefile b/astro/phoon/Makefile
index 111aa212bec8..602835c2a264 100644
--- a/astro/phoon/Makefile
+++ b/astro/phoon/Makefile
@@ -17,6 +17,10 @@ COMMENT= Displays the phase of the moon
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_REINPLACE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" \
+ BINDIR=${LOCALBASE}/bin \
+ MANDIR=${MANPREFIX}/man/man1
+
MAN1= phoon.1
PLIST_FILES= bin/phoon
diff --git a/astro/phoon/files/patch-Makefile b/astro/phoon/files/patch-Makefile
deleted file mode 100644
index 93a0a4c417d7..000000000000
--- a/astro/phoon/files/patch-Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.orig Thu May 15 09:07:10 2003
-+++ Makefile Thu May 15 09:08:24 2003
-@@ -1,13 +1,13 @@
- # Makefile for phoon
-
--BINDIR = /usr/local/bin
--MANDIR = /usr/local/man/man1
-+BINDIR = ${PREFIX}/bin
-+MANDIR = ${MANPREFIX}/man/man1
-
- DEFINES = -DOS_BSD
- #DEFINES = -DOS_SYSV
-
--CC = gcc
--CFLAGS = -O $(DEFINES)
-+CC ?= gcc
-+CFLAGS ?= ${CFLAGS}
-
- LDFLAGS = -s
-
-@@ -15,10 +15,10 @@
- all: phoon
-
- phoon: phoon.o date_parse.o astro.o
-- $(CC) $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
-+ ${CC} $(LDFLAGS) -o phoon phoon.o date_parse.o astro.o -lm
-
- .c.o:
-- $(CC) $(CFLAGS) -c $<
-+ ${CC} $(CFLAGS) -c $<
-
- date_parse.o: date_parse.h
- astro.o: astro.h