aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorbofh <bofh@FreeBSD.org>2016-06-10 04:50:14 +0800
committerbofh <bofh@FreeBSD.org>2016-06-10 04:50:14 +0800
commit133f2d9d82b09df82b701e40422ea365f2908a9c (patch)
tree3df87e6dd964172a963e2f0776211c5d9c101398 /astro
parent04460641df45e5ceb3fbb90a0f27987ce92adbde (diff)
downloadfreebsd-ports-gnome-133f2d9d82b09df82b701e40422ea365f2908a9c.tar.gz
freebsd-ports-gnome-133f2d9d82b09df82b701e40422ea365f2908a9c.tar.zst
freebsd-ports-gnome-133f2d9d82b09df82b701e40422ea365f2908a9c.zip
astro/routino: Install shared library
PR: 210062 Submitted by: cmt
Diffstat (limited to 'astro')
-rw-r--r--astro/routino/Makefile13
-rw-r--r--astro/routino/files/patch-doc_Makefile28
-rw-r--r--astro/routino/files/patch-extras_find-fixme_Makefile42
-rw-r--r--astro/routino/files/patch-src_Makefile43
-rw-r--r--astro/routino/files/patch-web_Makefile60
-rw-r--r--astro/routino/files/patch-xml_Makefile19
-rw-r--r--astro/routino/pkg-plist6
7 files changed, 209 insertions, 2 deletions
diff --git a/astro/routino/Makefile b/astro/routino/Makefile
index c94a672009c1..43ecbc4647ae 100644
--- a/astro/routino/Makefile
+++ b/astro/routino/Makefile
@@ -13,20 +13,29 @@ LICENSE= AGPLv3
OPTIONS_DEFINE= DOCS
USES= gmake perl5 tar:tgz
-#USE_GCC= any
USE_LDCONFIG= yes
-#MAKE_JOBS_UNSAFE= yes
post-patch:
${REINPLACE_CMD} 's|doc/routino|share/doc/routino|' \
${WRKSRC}/Makefile.conf
${REINPLACE_CMD} 's|gcc|${CC}|' \
${WRKSRC}/Makefile.conf
+
post-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC}/web && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR} \
"! -name Makefile")
+ ${CHMOD} 0644 ${STAGEDIR}${PREFIX}/lib/lib*
+ ${CHMOD} 0755 ${STAGEDIR}${PREFIX}/bin/*
+ ${CHMOD} 0755 ${STAGEDIR}${WWWDIR}/bin/*
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libroutino*.so
+ ${RM} ${STAGEDIR}${PREFIX}/lib/libroutino*.so.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
${STRIP_CMD} ${STAGEDIR}${WWWDIR}/bin/*
+.for f in routino.so.0.0.0 routino-slim.so.0.0.0
+ ${LN} -sf lib${f} ${STAGEDIR}${PREFIX}/lib/lib${f:R:R}
+ ${LN} -sf lib${f:R:R} ${STAGEDIR}${PREFIX}/lib/lib${f:R:R:R}
+.endfor
.include <bsd.port.mk>
diff --git a/astro/routino/files/patch-doc_Makefile b/astro/routino/files/patch-doc_Makefile
new file mode 100644
index 000000000000..a4ac4da5356e
--- /dev/null
+++ b/astro/routino/files/patch-doc_Makefile
@@ -0,0 +1,28 @@
+--- doc/Makefile.orig 2016-06-04 17:01:05 UTC
++++ doc/Makefile
+@@ -43,19 +43,19 @@ install: install-txt install-html
+ install-txt:
+ @[ -d $(DESTDIR)$(docdir) ] || mkdir -p $(DESTDIR)$(docdir)
+ @for file in $(TOP_FILES); do \
+- echo cp $$file $(DESTDIR)$(docdir) ;\
+- cp -f $$file $(DESTDIR)$(docdir) ;\
++ echo install $$file $(DESTDIR)$(docdir) ;\
++ install $$file $(DESTDIR)$(docdir) ;\
+ done
+ @for file in $(TXT_FILES); do \
+- echo cp $$file $(DESTDIR)$(docdir) ;\
+- cp -f $$file $(DESTDIR)$(docdir) ;\
++ echo install $$file $(DESTDIR)$(docdir) ;\
++ install $$file $(DESTDIR)$(docdir) ;\
+ done
+
+ install-html:
+ @[ -d $(DESTDIR)$(docdir)/html ] || mkdir -p $(DESTDIR)$(docdir)/html
+ @for file in $(HTML_FILES); do \
+- echo cp html/$$file $(DESTDIR)$(docdir)/html ;\
+- cp -f html/$$file $(DESTDIR)$(docdir)/html ;\
++ echo install html/$$file $(DESTDIR)$(docdir)/html ;\
++ install html/$$file $(DESTDIR)$(docdir)/html ;\
+ done
+
+ ########
diff --git a/astro/routino/files/patch-extras_find-fixme_Makefile b/astro/routino/files/patch-extras_find-fixme_Makefile
new file mode 100644
index 000000000000..32ef40c00de8
--- /dev/null
+++ b/astro/routino/files/patch-extras_find-fixme_Makefile
@@ -0,0 +1,42 @@
+--- extras/find-fixme/Makefile.orig 2016-06-04 17:12:29 UTC
++++ extras/find-fixme/Makefile
+@@ -52,8 +52,8 @@ all-bin: $(EXE)
+ @[ -d $(WEBBINDIR) ] || mkdir -p $(WEBBINDIR)
+ @for file in $(EXE); do \
+ if [ ! -f $(WEBBINDIR)/$$file ] || [ $$file -nt $(WEBBINDIR)/$$file ]; then \
+- echo cp $$file $(WEBBINDIR) ;\
+- cp -f $$file $(WEBBINDIR) ;\
++ echo install $$file $(WEBBINDIR) ;\
++ install $$file $(WEBBINDIR) ;\
+ fi ;\
+ done
+
+@@ -61,22 +61,22 @@ all-data:
+ @[ -d $(WEBDATADIR) ] || mkdir -p $(WEBDATADIR)
+ @for file in $(DATA); do \
+ if [ ! -f $(WEBDATADIR)/$$file ] || [ $$file -nt $(WEBDATADIR)/$$file ]; then \
+- echo cp $$file $(WEBDATADIR) ;\
+- cp -f $$file $(WEBDATADIR) ;\
++ echo install $$file $(WEBDATADIR) ;\
++ install $$file $(WEBDATADIR) ;\
+ fi ;\
+ done
+
+ all-www:
+ @for file in $(WWW_COPY); do \
+ if [ ! -f $(WEBWWWDIR)/$$file ] || [ $(ROUTINO_WEBWWWDIR)/$$file -nt $(WEBWWWDIR)/$$file ]; then \
+- echo cp $(ROUTINO_WEBWWWDIR)/$$file $(WEBWWWDIR) ;\
+- cp -f $(ROUTINO_WEBWWWDIR)/$$file $(WEBWWWDIR) ;\
++ echo install $(ROUTINO_WEBWWWDIR)/$$file $(WEBWWWDIR) ;\
++ install $(ROUTINO_WEBWWWDIR)/$$file $(WEBWWWDIR) ;\
+ fi ;\
+ done
+ @for file in $(DOC_COPY); do \
+ if [ ! -f $(WEBWWWDIR)/$$file ] || [ $(ROUTINO_DOCDIR)/$$file -nt $(WEBWWWDIR)/$$file ]; then \
+- echo cp $(ROUTINO_DOCDIR)/$$file $(WEBWWWDIR) ;\
+- cp -f $(ROUTINO_DOCDIR)/$$file $(WEBWWWDIR) ;\
++ echo install $(ROUTINO_DOCDIR)/$$file $(WEBWWWDIR) ;\
++ install $(ROUTINO_DOCDIR)/$$file $(WEBWWWDIR) ;\
+ fi ;\
+ done
+
diff --git a/astro/routino/files/patch-src_Makefile b/astro/routino/files/patch-src_Makefile
new file mode 100644
index 000000000000..a750f1ea5051
--- /dev/null
+++ b/astro/routino/files/patch-src_Makefile
@@ -0,0 +1,43 @@
+--- src/Makefile.orig 2015-09-29 18:09:59 UTC
++++ src/Makefile
+@@ -38,9 +38,7 @@ EXE=planetsplitter$(.EXE) planetsplitter
+ router+lib$(.EXE) router+lib-slim$(.EXE)
+
+ ifneq ($(HOST),MINGW)
+-LIB =libroutino.so libroutino-slim.so
+-LIB+=libroutino.so.$(SOVERSION) libroutino-slim.so.$(SOVERSION)
+-LIB+=libroutino.so.$(LIBVERSION) libroutino-slim.so.$(LIBVERSION)
++LIB=libroutino.so.$(LIBVERSION) libroutino-slim.so.$(LIBVERSION)
+ else
+ LIB =routino.dll routino-slim.dll
+ LIB+=routino.def routino-slim.def
+@@ -284,22 +282,23 @@ install-local: all-local
+ @[ -d $(DESTDIR)$(bindir) ] || mkdir -p $(DESTDIR)$(bindir)
+ @for file in $(EXE); do \
+ if [ -f $$file ]; then \
+- echo cp $$file $(DESTDIR)$(bindir) ;\
+- cp -f $$file $(DESTDIR)$(bindir) ;\
++ echo install -s $$file $(DESTDIR)$(bindir) ;\
++ install -s $$file $(DESTDIR)$(bindir) ;\
+ fi ;\
+ done
+ @[ -d $(DESTDIR)$(incdir) ] || mkdir -p $(DESTDIR)$(incdir)
+ @for file in $(INC); do \
+ if [ -f $$file ]; then \
+- echo cp $$file $(DESTDIR)$(incdir) ;\
+- cp -f $$file $(DESTDIR)$(incdir) ;\
++ echo install $$file $(DESTDIR)$(incdir) ;\
++ install $$file $(DESTDIR)$(incdir) ;\
+ fi ;\
+ done
+ @[ -d $(DESTDIR)$(libdir) ] || mkdir -p $(DESTDIR)$(libdir)
++ echo $(LIB)
+ @for file in $(LIB); do \
+ if [ -f $$file ]; then \
+- echo cp $$file $(DESTDIR)$(libdir) ;\
+- cp -df $$file $(DESTDIR)$(libdir) ;\
++ echo install -s $$file $(DESTDIR)$(libdir) ;\
++ install -s $$file $(DESTDIR)$(libdir) ;\
+ fi ;\
+ done
+
diff --git a/astro/routino/files/patch-web_Makefile b/astro/routino/files/patch-web_Makefile
new file mode 100644
index 000000000000..e87a7becd44d
--- /dev/null
+++ b/astro/routino/files/patch-web_Makefile
@@ -0,0 +1,60 @@
+--- web/Makefile.orig 2016-06-04 17:03:11 UTC
++++ web/Makefile
+@@ -64,8 +64,8 @@ all-bin: all-exe
+ @[ -d $(WEBBINDIR) ] || mkdir -p $(WEBBINDIR)
+ @for file in $(EXE_FILES); do \
+ if [ -f $(SRCDIR)/$$file -a ! -f $(WEBBINDIR)/$$file ] || [ $(SRCDIR)/$$file -nt $(WEBBINDIR)/$$file ]; then \
+- echo cp $(SRCDIR)/$$file $(WEBBINDIR) ;\
+- cp -f $(SRCDIR)/$$file $(WEBBINDIR) ;\
++ echo install $(SRCDIR)/$$file $(WEBBINDIR) ;\
++ install $(SRCDIR)/$$file $(WEBBINDIR) ;\
+ fi ;\
+ done
+
+@@ -75,14 +75,14 @@ all-data: all-xml
+ @[ -d $(WEBDATADIR) ] || mkdir -p $(WEBDATADIR)
+ @for file in $(STANDARD_XML_FILES); do \
+ if [ ! -f $(WEBDATADIR)/$$file ] || [ $(XMLDIR)/routino-$$file -nt $(WEBDATADIR)/$$file ]; then \
+- echo cp $(XMLDIR)/routino-$$file $(WEBDATADIR)/$$file ;\
+- cp -f $(XMLDIR)/routino-$$file $(WEBDATADIR)/$$file ;\
++ echo install $(XMLDIR)/routino-$$file $(WEBDATADIR)/$$file ;\
++ install $(XMLDIR)/routino-$$file $(WEBDATADIR)/$$file ;\
+ fi ;\
+ done
+ @for file in $(SPECIAL_XML_FILES); do \
+ if [ ! -f $(WEBDATADIR)/$$file ] || [ $(XMLDIR)/$$file -nt $(WEBDATADIR)/$$file ]; then \
+- echo cp $(XMLDIR)/$$file $(WEBDATADIR)/$$file ;\
+- cp -f $(XMLDIR)/$$file $(WEBDATADIR)/$$file ;\
++ echo install $(XMLDIR)/$$file $(WEBDATADIR)/$$file ;\
++ install $(XMLDIR)/$$file $(WEBDATADIR)/$$file ;\
+ fi ;\
+ done
+
+@@ -92,8 +92,8 @@ all-doc:
+ @[ -d $(WEBDOCDIR) ] || mkdir -p $(WEBDOCDIR)
+ @for file in $(DOC_FILES); do \
+ if [ ! -f $(WEBDOCDIR)/$$file ] || [ $(DOCDIR)/html/$$file -nt $(WEBDOCDIR)/$$file ]; then \
+- echo cp $(DOCDIR)/html/$$file $(WEBDOCDIR) ;\
+- cp -f $(DOCDIR)/html/$$file $(WEBDOCDIR) ;\
++ echo install $(DOCDIR)/html/$$file $(WEBDOCDIR) ;\
++ install $(DOCDIR)/html/$$file $(WEBDOCDIR) ;\
+ fi ;\
+ done
+
+@@ -116,12 +116,12 @@ all-translations: $(WEBWWWDIR)/router.ht
+ ifeq ($(HOST),MINGW)
+
+ $(WEBWWWDIR)/router.html: $(WEBWWWDIR)/router.html.en
+- @echo cp $< $@
+- @cp -f $< $@
++ @echo install $< $@
++ @install $< $@
+
+ $(WEBWWWDIR)/visualiser.html: $(WEBWWWDIR)/visualiser.html.en
+- @echo cp $< $@
+- @cp -f $< $@
++ @echo install $< $@
++ @install $< $@
+
+ else
+
diff --git a/astro/routino/files/patch-xml_Makefile b/astro/routino/files/patch-xml_Makefile
new file mode 100644
index 000000000000..690b3093f495
--- /dev/null
+++ b/astro/routino/files/patch-xml_Makefile
@@ -0,0 +1,19 @@
+--- xml/Makefile.orig 2016-06-04 17:08:07 UTC
++++ xml/Makefile
+@@ -56,12 +56,12 @@ test:
+ install: all
+ @[ -d $(DESTDIR)$(datadir) ] || mkdir -p $(DESTDIR)$(datadir)
+ @for file in $(STANDARD_FILES) ; do \
+- echo cp routino-$$file $(DESTDIR)$(datadir)/$$file ;\
+- cp -f routino-$$file $(DESTDIR)$(datadir)/$$file ;\
++ echo install routino-$$file $(DESTDIR)$(datadir)/$$file ;\
++ install routino-$$file $(DESTDIR)$(datadir)/$$file ;\
+ done
+ @for file in $(SPECIAL_FILES); do \
+- echo cp $$file $(DESTDIR)$(datadir)/$$file ;\
+- cp -f $$file $(DESTDIR)$(datadir)/$$file ;\
++ echo install $$file $(DESTDIR)$(datadir)/$$file ;\
++ install $$file $(DESTDIR)$(datadir)/$$file ;\
+ done
+
+ ########
diff --git a/astro/routino/pkg-plist b/astro/routino/pkg-plist
index 1f8bb416b4a5..1c6b723b18fd 100644
--- a/astro/routino/pkg-plist
+++ b/astro/routino/pkg-plist
@@ -35,6 +35,12 @@ bin/router-slim
%%PORTDOCS%%%%DOCSDIR%%/html/tagging.html
%%PORTDOCS%%%%DOCSDIR%%/html/usage.html
include/routino.h
+lib/libroutino-slim.so
+lib/libroutino-slim.so.0
+lib/libroutino-slim.so.0.0.0
+lib/libroutino.so
+lib/libroutino.so.0
+lib/libroutino.so.0.0.0
%%DATADIR%%/profiles.xml
%%DATADIR%%/tagging-drive.xml
%%DATADIR%%/tagging-ride.xml