aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-08 11:03:38 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-08 11:03:38 +0800
commit4292a87d079f824137631670d0529cf16fecfcd1 (patch)
treed93e97617a06866d1b761f6f7b7eb55e00edb02c /astro
parent38751fd85fdfdcce492e908bac95ee106b06da27 (diff)
downloadfreebsd-ports-gnome-4292a87d079f824137631670d0529cf16fecfcd1.tar.gz
freebsd-ports-gnome-4292a87d079f824137631670d0529cf16fecfcd1.tar.zst
freebsd-ports-gnome-4292a87d079f824137631670d0529cf16fecfcd1.zip
- Build cfitsio compress/uncompress C files in zlib/
- Bump PORTREVISION for package change Tested by: cperciva, marino
Diffstat (limited to 'astro')
-rw-r--r--astro/cfitsio/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index cae05751d050..15972fbdf882 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cfitsio
PORTVERSION= 3.360
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/ \
http://heasarc.gsfc.nasa.gov/FTP/software/fitsio/c/oldvers/ \
@@ -22,8 +23,9 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= libcfitsio.a shared
CFLAGS+= -I${INCLUDEDIR}
-CONFIGURE_ARGS= ZLIB_SOURCES="" ac_cv_prog_FC=f2c
+CONFIGURE_ARGS= ac_cv_prog_FC=f2c
GNU_CONFIGURE= yes
+MAKE_ARGS= ZLIB_SOURCES="zlib/zcompress.c zlib/zuncompress.c"
LDFLAGS+= -L${LIBDIR} -lz
USE_LDCONFIG= yes
USES= pkgconfig
@@ -36,9 +38,6 @@ PORTDOCS= *
SHLIB_MAJOR_VER=2
SHLIB_MINOR_VER=${PORTVERSION:S/0$//}
-post-patch:
- @${REINPLACE_CMD} -e 's|$${ZLIB_SOURCES[:=a-z\.]*}||' ${WRKSRC}/Makefile.in
-
do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
cd ${WRKSRC}/ && ${INSTALL_LIB} libcfitsio.a libcfitsio.so.${SHLIB_MAJOR_VER}.${SHLIB_MINOR_VER} ${STAGEDIR}${PREFIX}/lib/