aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-10-19 03:33:24 +0800
committerswills <swills@FreeBSD.org>2018-10-19 03:33:24 +0800
commit6d62edd3bcc1dd8a4e4f944f8d23631beae13125 (patch)
tree0479cd201655914988765b18c3a65c5183702523 /astro
parent4cc08c5c4f21c77629e8507be772b03d0e4d5086 (diff)
downloadfreebsd-ports-gnome-6d62edd3bcc1dd8a4e4f944f8d23631beae13125.tar.gz
freebsd-ports-gnome-6d62edd3bcc1dd8a4e4f944f8d23631beae13125.tar.zst
freebsd-ports-gnome-6d62edd3bcc1dd8a4e4f944f8d23631beae13125.zip
astro/gpstk: Update to 2.10.6
PR: 232365 Submitted by: Nathan <ndowens@yahoo.com>
Diffstat (limited to 'astro')
-rw-r--r--astro/gpstk/Makefile19
-rw-r--r--astro/gpstk/distinfo6
-rw-r--r--astro/gpstk/pkg-plist85
3 files changed, 103 insertions, 7 deletions
diff --git a/astro/gpstk/Makefile b/astro/gpstk/Makefile
index 7e0ad0bf4e31..9fc0a8e070c9 100644
--- a/astro/gpstk/Makefile
+++ b/astro/gpstk/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= gpstk
-PORTVERSION= 2.10
+PORTVERSION= 2.10.6
DISTVERSIONPREFIX= v
CATEGORIES= astro devel
MAINTAINER= ports@FreeBSD.org
COMMENT= Toolkit for developing GPS applications
-LICENSE= LGPL3
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= multi
USES= cmake:outsource
USE_LDCONFIG= yes
@@ -18,4 +19,18 @@ USE_GITHUB= yes
GH_ACCOUNT= SGL-UT
GH_PROJECT= GPSTk
+DOCS= *.md
+EXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_SUB= yes
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/examples/|} ${STAGEDIR}${EXAMPLESDIR}
+
.include <bsd.port.mk>
diff --git a/astro/gpstk/distinfo b/astro/gpstk/distinfo
index 06314befad0d..8d18e42a49e8 100644
--- a/astro/gpstk/distinfo
+++ b/astro/gpstk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1509793047
-SHA256 (SGL-UT-GPSTk-v2.10_GH0.tar.gz) = 75aa04137b17b90a116700431b4170d0d423dca32374b4effbcfebe7b1c06017
-SIZE (SGL-UT-GPSTk-v2.10_GH0.tar.gz) = 123291552
+TIMESTAMP = 1539773681
+SHA256 (SGL-UT-GPSTk-v2.10.6_GH0.tar.gz) = 29a9deec5389da60f5dcac297fc813638206ec6cb949370bb15d61a6654abf64
+SIZE (SGL-UT-GPSTk-v2.10.6_GH0.tar.gz) = 123324592
diff --git a/astro/gpstk/pkg-plist b/astro/gpstk/pkg-plist
index 83c6fb6fe30b..1ba5c69ba0fb 100644
--- a/astro/gpstk/pkg-plist
+++ b/astro/gpstk/pkg-plist
@@ -84,6 +84,7 @@ include/gpstk/GPSWeekZcount.hpp
include/gpstk/GPSZcount.hpp
include/gpstk/GPS_URA.hpp
include/gpstk/GalEphemeris.hpp
+include/gpstk/GalileoEllipsoid.hpp
include/gpstk/GloEphemeris.hpp
include/gpstk/GloEphemerisStore.hpp
include/gpstk/GlobalTropModel.hpp
@@ -100,6 +101,7 @@ include/gpstk/LNavCrossSourceFilter.hpp
include/gpstk/LNavEmptyFilter.hpp
include/gpstk/LNavEphMaker.hpp
include/gpstk/LNavFilterData.hpp
+include/gpstk/LNavOrderFilter.hpp
include/gpstk/LNavParityFilter.hpp
include/gpstk/LNavTLMHOWFilter.hpp
include/gpstk/LinearClockModel.hpp
@@ -122,6 +124,7 @@ include/gpstk/NavFilter.hpp
include/gpstk/NavFilterKey.hpp
include/gpstk/NavFilterMgr.hpp
include/gpstk/NavID.hpp
+include/gpstk/NavOrderFilter.hpp
include/gpstk/NeillTropModel.hpp
include/gpstk/ORDEpoch.hpp
include/gpstk/ObsClockModel.hpp
@@ -210,6 +213,7 @@ include/gpstk/TabularSatStore.hpp
include/gpstk/TestUtil.hpp
include/gpstk/TimeConstants.hpp
include/gpstk/TimeConverters.hpp
+include/gpstk/TimeCorrection.hpp
include/gpstk/TimeRange.hpp
include/gpstk/TimeString.hpp
include/gpstk/TimeSystem.hpp
@@ -235,14 +239,91 @@ include/gpstk/convhelp.hpp
include/gpstk/expandtilde.hpp
include/gpstk/gps_constants.hpp
include/gpstk/gpstkplatform.h
-include/gpstk/msecHandler.hpp
include/gpstk/logstream.hpp
+include/gpstk/msecHandler.hpp
+include/gpstk/ord.hpp
include/gpstk/singleton.hpp
include/gpstk/stl_helpers.hpp
lib/libgpstk.so
lib/libgpstk.so.2.10
-lib/libgpstk.so.2.10.0
+lib/libgpstk.so.2.10.6
share/cmake/GPSTK/GPSTKConfig.cmake
share/cmake/GPSTK/GPSTKConfigVersion.cmake
share/cmake/GPSTK/GPSTKTargets-%%CMAKE_BUILD_TYPE%%.cmake
share/cmake/GPSTK/GPSTKTargets.cmake
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.md
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.LESSER.md
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.md
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.md
+%%PORTDOCS%%%%DOCSDIR%%/DOCUMENTATION.md
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.md
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.md
+%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
+%%PORTDOCS%%%%DOCSDIR%%/PYTHON.md
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%%%DOCSDIR%%/RELNOTES.md
+%%PORTDOCS%%%%DOCSDIR%%/TESTING.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CMakeLists.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/DE405.EPH
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/OCEAN-GOT00.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/PRN_GPS
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/acor1480.08o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/areq015o.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bahr1620.04m
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bahr1620.04n
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bahr1620.04o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bell0300.02o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bell030a.02o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bogt015o.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/brdc0300.02n
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/coco2370.04o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cro1015o.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ebre015x.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ebre0300.02o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ebre030a.02o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/evaconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example10.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example11.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example12.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example13.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example14.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example15.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example16.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example17.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example18.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example3.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example4.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example5.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example6.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example7.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example8.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example9.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/glps015o.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs05.atx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs12851.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs12852.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs12853.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs13354.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs13355.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs13356.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs14811.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs14812.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs14813.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs15665.sp3
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/igs_01.atx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kennedy-PLAN-EBRE.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kour015o.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/madr1480.08o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/navfilterex-pseudo-container.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/navfilterex-pseudo-inherit.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/navfilterex-pseudo.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/navfilterex.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/onsa2240.05o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plan015x.10o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/popconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pppconf.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scoa1480.08o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sfer1480.08o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tlse1480.08o