aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
committerade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
commit9291e9a32f6612ca0d4f25bdcb5c417e0451d313 (patch)
tree545e55afde412d844a25f5c03d6d51b17ceeebb9 /astro
parenta8a89c37fe338cbff0192ceeef27ccf7a13714a5 (diff)
downloadfreebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.gz
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.zst
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Diffstat (limited to 'astro')
-rw-r--r--astro/glunarclock/Makefile2
-rw-r--r--astro/gpsdrive/Makefile2
-rw-r--r--astro/libnova/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index 4771f1bf2d37..0bf597cca3ac 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -18,7 +18,7 @@ COMMENT= GNOME applet that displays the current phase of the Moon
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomepanel gail gnomehack gnomeprefix
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/astro/gpsdrive/Makefile b/astro/gpsdrive/Makefile
index af3612997610..49dd8b230c80 100644
--- a/astro/gpsdrive/Makefile
+++ b/astro/gpsdrive/Makefile
@@ -29,7 +29,7 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gtk20
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
USE_GCC= 3.2
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
diff --git a/astro/libnova/Makefile b/astro/libnova/Makefile
index 86813780e1f7..be0550a2ad18 100644
--- a/astro/libnova/Makefile
+++ b/astro/libnova/Makefile
@@ -18,7 +18,7 @@ COMMENT= Astronomical Calculation Library
USE_GNOME= gnometarget lthack
USE_REINPLACE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
post-patch: