aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
committermat <mat@FreeBSD.org>2018-06-21 01:05:41 +0800
commitb2012f72500300ecbba6933c68717ba52c454563 (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /astro
parente02e32ae84bd96a47a379dcd2c109efc58b41400 (diff)
downloadfreebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.gz
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.tar.zst
freebsd-ports-gnome-b2012f72500300ecbba6933c68717ba52c454563.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Diffstat (limited to 'astro')
-rw-r--r--astro/gpsd/Makefile6
-rw-r--r--astro/py-RO/Makefile8
-rw-r--r--astro/py-aipy/Makefile6
-rw-r--r--astro/py-astLib/Makefile8
-rw-r--r--astro/py-horoscopegenerator/Makefile2
-rw-r--r--astro/py-metpy/Makefile12
6 files changed, 21 insertions, 21 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index b40216a42e72..77fc5540b368 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -138,9 +138,9 @@ QTBIND_PLIST_SUB= QTBIND=""
QTBIND_PLIST_SUB_OFF= QTBIND="@comment "
RECONFIGURE_MAKE_ARGS_OFF= reconfigure=no
CPPBIND_MAKE_ARGS_OFF= libgpsmm=no
-X11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${FLAVOR}
-#X11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${FLAVOR}
+X11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${PY_FLAVOR}
+#X11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>=0:graphics/py-cairo@${PY_FLAVOR}
X11_USE= GNOME=gtk30
# Build control
diff --git a/astro/py-RO/Makefile b/astro/py-RO/Makefile
index c3878478be41..9bef1b521669 100644
--- a/astro/py-RO/Makefile
+++ b/astro/py-RO/Makefile
@@ -13,7 +13,7 @@ COMMENT= Package of Python astronomical utilities
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:math/py-numpy@${FLAVOR}
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/numeric.py:math/py-numpy@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= ASTROPY MATPLOTLIB PYGAME
@@ -27,8 +27,8 @@ NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
-ASTROPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=0:astro/py-astropy@${FLAVOR}
-MATPLOTLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
-PYGAME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=1.8.1:devel/py-game@${FLAVOR}
+ASTROPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=0:astro/py-astropy@${PY_FLAVOR}
+MATPLOTLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${PY_FLAVOR}
+PYGAME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>=1.8.1:devel/py-game@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
index 0ff61e316e81..a7c6756a5c01 100644
--- a/astro/py-aipy/Makefile
+++ b/astro/py-aipy/Makefile
@@ -14,9 +14,9 @@ COMMENT= Astronomical Interferometry in PYthon
LICENSE= GPLv2+
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}pyephem>=0:astro/pyephem@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}astropy>=1.0:astro/py-astropy@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pyephem>=0:astro/pyephem@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}astropy>=1.0:astro/py-astropy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= python:2.7
diff --git a/astro/py-astLib/Makefile b/astro/py-astLib/Makefile
index ca87dc10ee4a..31eb252d4bfa 100644
--- a/astro/py-astLib/Makefile
+++ b/astro/py-astLib/Makefile
@@ -13,11 +13,11 @@ COMMENT= Astronomy modules for Python
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>=1.1:astro/py-astropy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.98:math/py-matplotlib@${PY_FLAVOR} \
${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.7.0:science/py-scipy@${PY_FLAVOR}
PORTSCOUT= skipv:0.15,0.17,0.17.1 # incorrect versioning upstream
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
index e9292c16bb0e..4af32c9d96a0 100644
--- a/astro/py-horoscopegenerator/Makefile
+++ b/astro/py-horoscopegenerator/Makefile
@@ -16,6 +16,6 @@ NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/astro/py-metpy/Makefile b/astro/py-metpy/Makefile
index 0bdb803f08a2..73647026f345 100644
--- a/astro/py-metpy/Makefile
+++ b/astro/py-metpy/Makefile
@@ -15,12 +15,12 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${ENUM34} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4:math/py-matplotlib@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.10.0:math/py-numpy@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pint>=0.8:converters/py-pint@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyproj>=1.9.4:graphics/py-pyproj@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>=0.14:science/py-scipy@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}xarray>=0.9.6:devel/py-xarray@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.10.0:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pint>=0.8:converters/py-pint@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyproj>=1.9.4:graphics/py-pyproj@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.14:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xarray>=0.9.6:devel/py-xarray@${PY_FLAVOR}
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils