aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-09 18:09:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-09 18:09:03 +0800
commitd8ce359e2bcb6226ef1866d16ddfc2f4173ff8ed (patch)
treee66a2b42869f4f4f60a32912246052e44c68f737 /astro
parentd53abfe7b7368188880f00319ae2114390259eed (diff)
downloadfreebsd-ports-gnome-d8ce359e2bcb6226ef1866d16ddfc2f4173ff8ed.tar.gz
freebsd-ports-gnome-d8ce359e2bcb6226ef1866d16ddfc2f4173ff8ed.tar.zst
freebsd-ports-gnome-d8ce359e2bcb6226ef1866d16ddfc2f4173ff8ed.zip
- Install data files (airports, places, stations, zctas and zones)
- Use CONFLICTS_INSTALL instead of CONFLICTS - Use USES=shebangfix - Add post-install: message - Bump PORTREVISION for package change PR: ports/181955 Submitted by: hiren
Diffstat (limited to 'astro')
-rw-r--r--astro/weather/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index 9e1823979de0..2db4a551ac8a 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -3,6 +3,7 @@
PORTNAME= weather
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= astro python
MASTER_SITES= http://fungi.yuggoth.org/weather/src/ \
LOCAL/sunpoet
@@ -12,10 +13,11 @@ COMMENT= Utility to provide current weather conditions and forecasts
LICENSE= ISCL
-CONFLICTS= expect-[0-9]* expect-nox11-[0-9]*
+CONFLICTS_INSTALL= expect-[0-9]* expect-nox11-[0-9]*
USE_PYTHON= yes
USE_XZ= yes
+USES= shebangfix
MAN1= ${PORTNAME}.1
MAN5= ${PORTNAME}rc.5
@@ -23,9 +25,11 @@ PLIST_FILES= bin/${PORTNAME} \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.pyc \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.pyo
+PORTDATA= airports places stations zctas zones
-post-patch:
- @${REINPLACE_CMD} -e '1 s|/usr/bin/env python|${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
+SHEBANG_FILES= ${PORTNAME}
+python_OLD_CMD= ${SETENV} python
+python_CMD= ${PYTHON_CMD}
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}/${PORTNAME}.py
@@ -36,5 +40,15 @@ do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTNAME}.py ${PORTNAME}.pyc ${PORTNAME}.pyo ${PYTHON_SITELIBDIR}/
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}rc.5 ${MANPREFIX}/man/man5/${PORTNAME}rc.5
+ ${MKDIR} ${DATADIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDATA} ${DATADIR}/
+
+post-install:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Please add the following to your .weatherrc in order to use installed data files:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "[default]"
+ @${ECHO_MSG} "setpath = ${DATADIR}"
+ @${ECHO_MSG} ""
.include <bsd.port.mk>