aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-06-25 04:08:27 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-06-25 04:08:27 +0800
commite558a4fdf9a82877656f646f5495169bd2578439 (patch)
tree4147f0b7bc2a4e0ecf82945143afbc477a8c1e74 /astro
parent7381ed1414625318afd8ff68397e5c79006b8161 (diff)
downloadfreebsd-ports-gnome-e558a4fdf9a82877656f646f5495169bd2578439.tar.gz
freebsd-ports-gnome-e558a4fdf9a82877656f646f5495169bd2578439.tar.zst
freebsd-ports-gnome-e558a4fdf9a82877656f646f5495169bd2578439.zip
Add py-spacetrack 0.13.1
spacetrack is a python module for Space-Track. WWW: https://github.com/python-astrodynamics/spacetrack
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-spacetrack/Makefile39
-rw-r--r--astro/py-spacetrack/distinfo3
-rw-r--r--astro/py-spacetrack/pkg-descr3
4 files changed, 46 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 1a87a2273ce5..adb201a8f514 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -85,6 +85,7 @@
SUBDIR += py-RO
SUBDIR += py-aipy
SUBDIR += py-astLib
+ SUBDIR += py-astro
SUBDIR += py-astropy
SUBDIR += py-horoscopegenerator
SUBDIR += py-metar
diff --git a/astro/py-spacetrack/Makefile b/astro/py-spacetrack/Makefile
new file mode 100644
index 000000000000..8eb4f905c768
--- /dev/null
+++ b/astro/py-spacetrack/Makefile
@@ -0,0 +1,39 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spacetrack
+PORTVERSION= 0.13.1
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python client for space-track.org
+
+LICENSE= MIT
+#LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}logbook>=0.12.3:devel/py-logbook@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ratelimiter>=1.2.0:devel/py-ratelimiter@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}represent>=1.4.0:devel/py-represent@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}responses>=0:devel/py-responses@${PY_FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3300
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
+.endif
+
+.if ${PYTHON_REL} >= 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}aiohttp>=2.0:www/py-aiohttp@${PY_FLAVOR}
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/astro/py-spacetrack/distinfo b/astro/py-spacetrack/distinfo
new file mode 100644
index 000000000000..e11a33a5148d
--- /dev/null
+++ b/astro/py-spacetrack/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529857820
+SHA256 (spacetrack-0.13.1.tar.gz) = 41038c8d4fd28861cdd5e2d9afa7dede76ff381b69cb6957770c1ff146377f0a
+SIZE (spacetrack-0.13.1.tar.gz) = 28193
diff --git a/astro/py-spacetrack/pkg-descr b/astro/py-spacetrack/pkg-descr
new file mode 100644
index 000000000000..e9ec09a9b39c
--- /dev/null
+++ b/astro/py-spacetrack/pkg-descr
@@ -0,0 +1,3 @@
+spacetrack is a python module for Space-Track.
+
+WWW: https://github.com/python-astrodynamics/spacetrack