aboutsummaryrefslogtreecommitdiffstats
path: root/audio/abraca/Makefile
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-05-09 04:10:59 +0800
committermadpilot <madpilot@FreeBSD.org>2012-05-09 04:10:59 +0800
commit2735ce11e0af0069c9e8c7107924fef5951b8045 (patch)
treec15faeafdf78cfab680c0f3d48beede363ae8554 /audio/abraca/Makefile
parent404a068aa581011802ee72aaac9158292d5c8ff5 (diff)
downloadfreebsd-ports-gnome-2735ce11e0af0069c9e8c7107924fef5951b8045.tar.gz
freebsd-ports-gnome-2735ce11e0af0069c9e8c7107924fef5951b8045.tar.zst
freebsd-ports-gnome-2735ce11e0af0069c9e8c7107924fef5951b8045.zip
- Update to 0.7.0
- Update home page and MASTER_SITE Approved by: crees (mentor)
Diffstat (limited to 'audio/abraca/Makefile')
-rw-r--r--audio/abraca/Makefile33
1 files changed, 23 insertions, 10 deletions
diff --git a/audio/abraca/Makefile b/audio/abraca/Makefile
index 2041378a8392..14b09ba7f068 100644
--- a/audio/abraca/Makefile
+++ b/audio/abraca/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= abraca
-PORTVERSION= 0.6.0
+PORTVERSION= 0.7.0
CATEGORIES= audio
-MASTER_SITES= LOCAL/madpilot/abraca
+MASTER_SITES= http://cloud.github.com/downloads/Abraca/Abraca/
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Abraca is a GTK2 client for the XMMS2 music player
@@ -18,17 +18,30 @@ LIB_DEPENDS= xmmsclient.6:${PORTSDIR}/audio/xmms2 \
gee.2:${PORTSDIR}/devel/libgee
USE_SCONS= yes
-USE_GNOME= gtk20
+USE_GNOME= gtk30
-PLIST_FILES= bin/${PORTNAME}
+SCONS_ARGS= MANDIR=${MANPREFIX}/man
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/build/src/${PORTNAME} ${PREFIX}/bin
+MAN1= abraca.1
+MANCOMPRESSED= yes
-.include <bsd.port.pre.mk>
+OPTIONS= NLS "Enable gettext support" on
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS='@comment '
+.else
+PLIST_SUB+= NLS=''
+USE_GETTEXT= yes
+.endif
+
+post-configure:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's/%%NLS%%/0/' ${WRKSRC}/SConstruct
+.else
+ @${REINPLACE_CMD} -e 's/%%NLS%%/1/' ${WRKSRC}/SConstruct
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>