aboutsummaryrefslogtreecommitdiffstats
path: root/audio/amarok-kde4
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2006-12-12 18:42:46 +0800
committermich <mich@FreeBSD.org>2006-12-12 18:42:46 +0800
commitec5d1c9414fbfb81d96984e94303a463868ccf6b (patch)
tree496da2decb91acb3941d9f0c9d166eabd7e49881 /audio/amarok-kde4
parent1f592206b732c2ad7da4be9f8ae2a77365363fc0 (diff)
downloadfreebsd-ports-gnome-ec5d1c9414fbfb81d96984e94303a463868ccf6b.tar.gz
freebsd-ports-gnome-ec5d1c9414fbfb81d96984e94303a463868ccf6b.tar.zst
freebsd-ports-gnome-ec5d1c9414fbfb81d96984e94303a463868ccf6b.zip
- add MTP support [1]
- bump PORTREVISION (forgot in previous commit) PR: ports/106570 [1] Submitted by: Petar Zhivkov Petrov <pesho.petrov@gmail.com> [1]
Diffstat (limited to 'audio/amarok-kde4')
-rw-r--r--audio/amarok-kde4/Makefile11
-rw-r--r--audio/amarok-kde4/pkg-plist3
2 files changed, 13 insertions, 1 deletions
diff --git a/audio/amarok-kde4/Makefile b/audio/amarok-kde4/Makefile
index 998108432a29..bee7a57b4b06 100644
--- a/audio/amarok-kde4/Makefile
+++ b/audio/amarok-kde4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= amarok
PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
@@ -31,6 +31,7 @@ USE_LDCONFIG= yes
OPTIONS= GPOD "iPod support" on \
NJB "Creative Nomad and Dell support" on \
+ MTP "MTP device support" on \
XMMS "XMMS visualizations" off \
OPENGL "OpenGL support" on \
AMAZON "Amazon cover fetching support" on \
@@ -65,6 +66,14 @@ CONFIGURE_ARGS+=--with-libnjb
PLIST_SUB+= NJB=""
.endif
+.if !defined(WITH_MTP)
+PLIST_SUB+= MTP="@comment "
+.else
+LIB_DEPENDS+= mtp.3:${PORTSDIR}/audio/libmtp
+CONFIGURE_ARGS+=--with-libmtp
+PLIST_SUB+= MTP=""
+.endif
+
.if !defined(WITH_XMMS)
PLIST_SUB+= XMMS="@comment "
CONFIGURE_ARGS+=--without-xmms
diff --git a/audio/amarok-kde4/pkg-plist b/audio/amarok-kde4/pkg-plist
index 0120b2d5eae2..a1096c92e3a2 100644
--- a/audio/amarok-kde4/pkg-plist
+++ b/audio/amarok-kde4/pkg-plist
@@ -29,6 +29,9 @@ lib/kde3/libamarok_smb-device.a
%%NJB%%lib/kde3/libamarok_njb-mediadevice.so
%%NJB%%lib/kde3/libamarok_njb-mediadevice.la
%%NJB%%lib/kde3/libamarok_njb-mediadevice.a
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.so
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.la
+%%MTP%%lib/kde3/libamarok_mtp-mediadevice.a
lib/kde3/libamarok_generic-mediadevice.so
lib/kde3/libamarok_generic-mediadevice.la
lib/kde3/libamarok_generic-mediadevice.a