aboutsummaryrefslogtreecommitdiffstats
path: root/audio/amarok
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2012-02-26 23:22:37 +0800
committernox <nox@FreeBSD.org>2012-02-26 23:22:37 +0800
commit43ee86bbe02ddd769636f9076096c9871a4f8b95 (patch)
treedeefe265cb512ac12217d02a6d9cf5f09e408e70 /audio/amarok
parent3d59b95822df4fff8ceaf461bcf666bc3ecd7e26 (diff)
downloadfreebsd-ports-gnome-43ee86bbe02ddd769636f9076096c9871a4f8b95.tar.gz
freebsd-ports-gnome-43ee86bbe02ddd769636f9076096c9871a4f8b95.tar.zst
freebsd-ports-gnome-43ee86bbe02ddd769636f9076096c9871a4f8b95.zip
- Update multimedia/libxine to 1.2.1 with a commit merged from hg
to fix DVB support. (which still is broken for tuners using hardware pid filtering, like when running webcamd with "-m dvb-usb-init.force_pid_filter_usage=1".) - Add patches to fix build of ports depending on libxine to: audio/amarok, graphics/gimageview [1], graphics/pornview [1], graphics/osg [2], graphics/osg-devel [2], multimedia/emotion, x11/kdelibs4 [3], multimedia/kmplayer, multimedia/konverter, multimedia/qdvdauthor [4], multimedia/vdr-plugin-xineliboutput, multimedia/xfce4-media [5], multimedia/xine_artsplugin, multimedia/k9copy-kde4 [6] - Fix RUN_DEPENDS= xine... which should be LIB_DEPENDS for audio/atunes . [7] - Mark multimedia/phonon-xine BROKEN which refuses to build with libxine 1.2.x and is deprecated upstream. [3] - Disable XINE knob for x11/eaglemode for which I don't have a fix. [2] - Note: multimedia/kaffeine runs after rakuco's x11/kdelibs4 fix, but it only shows a green window at least with mp4 or ts files. (avi files and audio still work.) It seems the kaffeine developers have found this too and are now switching away from libxine in their git repo - so I guess we'll have a broken kaffeine at least until they release a new version. - Bump PORTREVISIONs for ports depending on libxine by default. - Add optional libbluray support to multimedia/libxine and multimedia/vdr-plugin-xineliboutput. PR: ports/165057 [6] Submitted by: nox (self) [6], rakuco [3] Approved by: dinoex (maintainer, via irc) [1], amdmi3 (maintainer, via private email) [2], kde@ (rakuco, via irc) [3], Phil Oleson <oz@nixil.net> (maintainer, via private email) [4], xfce@ (rene, via irc) [5], Eduardo Gielamo Oliveira <egoliveira@gmail.com> (maintainer) [6], lme (maintainer, via irc) [7] Thanx to: Darren Salt (upstream libxine maintainer) for a few hints on irc to help with patching ports depending on deprecated libxine features
Diffstat (limited to 'audio/amarok')
-rw-r--r--audio/amarok/Makefile4
-rw-r--r--audio/amarok/files/patch-src-engine-xine-xine-engine.cpp14
2 files changed, 16 insertions, 2 deletions
diff --git a/audio/amarok/Makefile b/audio/amarok/Makefile
index e7d142700031..9eaea4344a15 100644
--- a/audio/amarok/Makefile
+++ b/audio/amarok/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amarok
PORTVERSION= 1.4.10
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= audio kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
@@ -18,7 +18,7 @@ COMMENT= Media player for KDE
LIB_DEPENDS= tag.1:${PORTSDIR}/audio/taglib \
tunepimp.5:${PORTSDIR}/audio/libtunepimp \
mp4v2.10:${PORTSDIR}/multimedia/mp4v2 \
- xine.1:${PORTSDIR}/multimedia/libxine
+ xine.2:${PORTSDIR}/multimedia/libxine
MIN_OPTIONS_VER= ${PORTNAME}-1.4.1
diff --git a/audio/amarok/files/patch-src-engine-xine-xine-engine.cpp b/audio/amarok/files/patch-src-engine-xine-xine-engine.cpp
new file mode 100644
index 000000000000..83dcbfa62e8d
--- /dev/null
+++ b/audio/amarok/files/patch-src-engine-xine-xine-engine.cpp
@@ -0,0 +1,14 @@
+--- amarok/src/engine/xine/xine-engine.cpp.orig
++++ amarok/src/engine/xine/xine-engine.cpp
+@@ -1131,7 +1131,11 @@ bool XineEngine::metaDataForUrl(const KU
+
+ bool XineEngine::getAudioCDContents(const QString &device, KURL::List &urls)
+ {
++#if XINE_MAJOR_VERSION < 1 || (XINE_MAJOR_VERSION == 1 && XINE_MINOR_VERSION < 2)
+ char **xine_urls = NULL;
++#else
++ const char * const *xine_urls = NULL;
++#endif
+ int num;
+ int i = 0;
+