aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ario
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2013-09-28 01:36:31 +0800
committerGrzegorz Blach <gblach@FreeBSD.org>2013-09-28 01:36:31 +0800
commiteaf3a74aecac3c218e10dba2dcceb36c2f05a400 (patch)
treef1ac6e3b200bc322381f5abdcd2377d92df3e9d7 /audio/ario
parentee53e77fa4ab3e63a353d2b8a6d8b8f989a2b659 (diff)
downloadfreebsd-ports-gnome-eaf3a74aecac3c218e10dba2dcceb36c2f05a400.tar.gz
freebsd-ports-gnome-eaf3a74aecac3c218e10dba2dcceb36c2f05a400.tar.zst
freebsd-ports-gnome-eaf3a74aecac3c218e10dba2dcceb36c2f05a400.zip
- Convert USE_GNOME=gnomehack to USES=pathfix
- Convert to new LIB_DEPENDS syntax - Support staging Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'audio/ario')
-rw-r--r--audio/ario/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/audio/ario/Makefile b/audio/ario/Makefile
index 42f112fa0e2b..d504b26a5035 100644
--- a/audio/ario/Makefile
+++ b/audio/ario/Makefile
@@ -12,21 +12,20 @@ COMMENT= Ario is a GTK2 client for MPD
LICENSE= GPLv2
-LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- curl:${PORTSDIR}/ftp/curl \
- notify:${PORTSDIR}/devel/libnotify \
- soup:${PORTSDIR}/devel/libsoup \
- tag_c:${PORTSDIR}/audio/taglib \
- unique-1.0:${PORTSDIR}/x11-toolkits/unique \
- mpdclient:${PORTSDIR}/audio/libmpdclient
-
-NO_STAGE= yes
-USES= gmake pkgconfig
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libnotify.so:${PORTSDIR}/devel/libnotify \
+ libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
+ libtag_c.so:${PORTSDIR}/audio/taglib \
+ libunique-1.0.so:${PORTSDIR}/x11-toolkits/unique \
+ libmpdclient.so:${PORTSDIR}/audio/libmpdclient
+
+USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GNOME= gtk20 gnomehack
+USE_GNOME= gtk20
INSTALLS_ICONS= yes
OPTIONS_DEFINE= AVAHI NLS
@@ -35,7 +34,7 @@ AVAHI_DESC= Zeroconf support (Avahi)
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAVAHI}
-LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS+= libavahi-client.so:${PORTSDIR}/net/avahi-app
CONFIGURE_ARGS+= --enable-avahi
.else
CONFIGURE_ARGS+= --disable-avahi