aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ascd/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-03-01 00:13:26 +0800
committerpawel <pawel@FreeBSD.org>2014-03-01 00:13:26 +0800
commit68254a4d09d78c74329958d2d1577384adee7b27 (patch)
tree878d71a11afbb3b1fc600bbe9fa1569b44637c82 /audio/ascd/Makefile
parente0aef3045cb0c2e9d2cbcbff1c948b4ade4a0e47 (diff)
downloadfreebsd-ports-gnome-68254a4d09d78c74329958d2d1577384adee7b27.tar.gz
freebsd-ports-gnome-68254a4d09d78c74329958d2d1577384adee7b27.tar.zst
freebsd-ports-gnome-68254a4d09d78c74329958d2d1577384adee7b27.zip
Staging support
Diffstat (limited to 'audio/ascd/Makefile')
-rw-r--r--audio/ascd/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/ascd/Makefile b/audio/ascd/Makefile
index 0eb517b3ebe9..c8ffc67aea51 100644
--- a/audio/ascd/Makefile
+++ b/audio/ascd/Makefile
@@ -16,7 +16,6 @@ LICENSE= BSD
LIB_DEPENDS= libworkman.so:${PORTSDIR}/audio/libworkman
-NO_STAGE= yes
USES= imake
USE_XORG= xpm
@@ -24,8 +23,6 @@ USE_XORG= xpm
DATAFILES= ascd-0.13pr6-themes.tgz
THEMESDIR= ascd-0.13pr6-themes
-MAN1= ascd.1
-
post-patch:
@${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
${WRKSRC}/misc/config.h.default > ${WRKSRC}/config.h
@@ -33,11 +30,16 @@ post-patch:
${WRKSRC}/misc/dirs.h.default > ${WRKSRC}/dirs.h
@${CAT} ${WRKSRC}/version.h >> ${WRKSRC}/config.h
+post-configure:
+ @${REINPLACE_CMD} -E '/@(cp|cd)/ s,\(THEMESDIR\),\(DESTDIR\)$$&,g' \
+ ${WRKSRC}/Makefile
+
post-install:
@${ECHO_CMD} "AScd additional themes installation"
@${ECHO_CMD} ""
@${ECHO_CMD} "Untarring"
- @${TAR} xf ${WRKDIR}/${THEMESDIR}/themes.tar -C ${PREFIX}/share/ascd/Themes
+ @${TAR} xf ${WRKDIR}/${THEMESDIR}/themes.tar -C \
+ ${STAGEDIR}${PREFIX}/share/ascd/Themes
@${ECHO_CMD} "Done."
.include <bsd.port.mk>