aboutsummaryrefslogtreecommitdiffstats
path: root/audio/audacity/Makefile
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-03-18 14:51:28 +0800
committerriggs <riggs@FreeBSD.org>2016-03-18 14:51:28 +0800
commit8b70103b1e9b425ff21bbea8e403dcc3defcb102 (patch)
tree9fb5cceb873cee0a88a748d4a1d8703c5fd68fca /audio/audacity/Makefile
parentcdbf8ba0bb0975691c03863866d25c43fd9eab3f (diff)
downloadfreebsd-ports-gnome-8b70103b1e9b425ff21bbea8e403dcc3defcb102.tar.gz
freebsd-ports-gnome-8b70103b1e9b425ff21bbea8e403dcc3defcb102.tar.zst
freebsd-ports-gnome-8b70103b1e9b425ff21bbea8e403dcc3defcb102.zip
Add autoreconf libtool to USES; install headers to include, not DATADIR
This changeset brings in the necessary fixes in audacity's build system to use autoreconf and libtool in USES. (206914) First use case of this is to have audacity install its headers in the standard include path rather than DATADIR (207074). Bump PORTREVISION. PR: 206914, 207074 Submitted by: tatsuki_makino@hotmail.com Approved by: xxjack12xx@gmail.com (maintainer)
Diffstat (limited to 'audio/audacity/Makefile')
-rw-r--r--audio/audacity/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index ca8bc2dae1f1..9761ced96de2 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -3,7 +3,7 @@
PORTNAME= audacity
PORTVERSION= 2.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= https://github.com/audacity/audacity/archive/
DISTNAME= Audacity-${PORTVERSION}
@@ -25,8 +25,8 @@ BROKEN_powerpc64= Does not build
WRKSRC= ${WRKDIR}/${PORTNAME}-Audacity-${PORTVERSION}
GNU_CONFIGURE= yes
-USES= compiler:c++11-lib cpe desktop-file-utils gmake iconv pkgconfig shared-mime-info shebangfix dos2unix
-NLS_USES= gettext
+USES= autoreconf compiler:c++11-lib cpe desktop-file-utils gettext-tools gmake iconv libtool pkgconfig shared-mime-info shebangfix dos2unix
+NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_WITH= libintl-prefix="${LOCALBASE}"
OPTIONS_SUB= yes
@@ -135,10 +135,6 @@ VST_CONFIGURE_ENABLE= vst
CXXFLAGS+= -std=c++11
.endif
-post-configure:
- ${REINPLACE_CMD} -e '/SNDFILE_CFLAGS/s,%%LOCALBASE%%,${LOCALBASE},'\
- ${WRKSRC}/lib-src/libnyquist/Makefile
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}