aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aumix
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2009-11-03 02:23:57 +0800
committernaddy <naddy@FreeBSD.org>2009-11-03 02:23:57 +0800
commit17203713f39cd4b4994d27ceebd83fb5ca92cb0c (patch)
tree4b173de716dabf49b269ccaa48e8a469e991e9b7 /audio/aumix
parent0986b019ab2e584aefb4ba67853838af6520bdd9 (diff)
downloadfreebsd-ports-gnome-17203713f39cd4b4994d27ceebd83fb5ca92cb0c.tar.gz
freebsd-ports-gnome-17203713f39cd4b4994d27ceebd83fb5ca92cb0c.tar.zst
freebsd-ports-gnome-17203713f39cd4b4994d27ceebd83fb5ca92cb0c.zip
Always pass localized messages in UTF-8 to GTK+2.
Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'audio/aumix')
-rw-r--r--audio/aumix/Makefile6
-rw-r--r--audio/aumix/files/patch-src_common.c12
2 files changed, 15 insertions, 3 deletions
diff --git a/audio/aumix/Makefile b/audio/aumix/Makefile
index 41e87f765208..2cb7689c0203 100644
--- a/audio/aumix/Makefile
+++ b/audio/aumix/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aumix
PORTVERSION= 2.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF \
http://jpj.net/~trevor/aumix/ \
@@ -51,8 +51,8 @@ pre-extract:
@sleep 3
.endif
-do-patch:
- @${REINPLACE_CMD} -e "s:/etc:${PREFIX}/etc:" ${WRKSRC}/src/common.[c,h]
+pre-patch:
+ @${REINPLACE_CMD} -e "s:/etc:${PREFIX}/etc:" ${WRKSRC}/src/common.[ch]
.if (${HAVE_GNOME:Mgtk12}!="") && !defined(WITHOUT_ALL) && \
!defined(WITHOUT_GTK)&& !defined(WITH_GTK2)
diff --git a/audio/aumix/files/patch-src_common.c b/audio/aumix/files/patch-src_common.c
new file mode 100644
index 000000000000..67e50c8884bc
--- /dev/null
+++ b/audio/aumix/files/patch-src_common.c
@@ -0,0 +1,12 @@
+--- src/common.c.orig 2009-10-17 15:53:40.000000000 +0200
++++ src/common.c 2009-10-17 15:56:10.000000000 +0200
+@@ -216,6 +216,9 @@ int main(int argc, char *arg
+ #if defined (HAVE_GTK) || defined (HAVE_GTK1)
+ /* GTK+ stuff */
+ if (interactive == IN_GTK) {
++#if defined (HAVE_GTK) && defined (HAVE_NLS)
++ bind_textdomain_codeset((char *) PACKAGE, "UTF-8");
++#endif /* HAVE_GTK && HAVE_NLS */
+ #ifndef DUMMY_MIXER
+ if ((mixer_fd = open(device_filename, O_RDWR)) < 0)
+ return EOPENMIX;