aboutsummaryrefslogtreecommitdiffstats
path: root/audio/calf/files
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-08-02 23:03:19 +0800
committertijl <tijl@FreeBSD.org>2015-08-02 23:03:19 +0800
commit2593b8ce7a7784074d28066b8690c9c2da075fd7 (patch)
treeea36e7f5c3df09ecf07eacd3dfa1065817e07c56 /audio/calf/files
parentdfc31d8ad6426dcddd1e4f4718d93857c195b031 (diff)
downloadfreebsd-ports-gnome-2593b8ce7a7784074d28066b8690c9c2da075fd7.tar.gz
freebsd-ports-gnome-2593b8ce7a7784074d28066b8690c9c2da075fd7.tar.zst
freebsd-ports-gnome-2593b8ce7a7784074d28066b8690c9c2da075fd7.zip
By default libtool replaces -export-symbols <file> with -retain-symbols-file
<file> on ELF systems, but this doesn't really do what -export-symbols is meant to do. On GNU ELF systems it converts <file> to a simple version script first and then uses -version-script instead of -retain-symbols-file. Let USES=libtool patch libtool scripts to do this on all systems with GNU ld(1). Bump PORTREVISION on all ports where the build log contains -export-symbols. audio/calf: This port builds a module that now exports only one function, but it also builds a number of executables that link to this module and expect to see other functions. Because it's already a bit dodgy to link to a module (libtool warns about this) let the module continue to export only one function and instead build an ordinary library from the same source that the executables can link to. Fix a number of other issues in the same Makefile.am and clean up the port Makefile. japanese/scim-honoka: Tries to hide all symbols that start with an underscore, but because this library is written in C++ all symbols start with _Z so it ends up hiding everything. Just don't hide anything at all like the textproc/scim configure script does. multimedia/schroedinger: Apply an upstream patch. textproc/scim-input-pad: Same as japanese/scim-honoka. PR: 201922 Approved by: portmgr (antoine) Exp-run by: antoine
Diffstat (limited to 'audio/calf/files')
-rw-r--r--audio/calf/files/patch-configure.ac20
-rw-r--r--audio/calf/files/patch-src-Makefile.am108
-rw-r--r--audio/calf/files/patch-src-giface.cpp11
-rw-r--r--audio/calf/files/patch-src-monosynth.cpp11
4 files changed, 150 insertions, 0 deletions
diff --git a/audio/calf/files/patch-configure.ac b/audio/calf/files/patch-configure.ac
new file mode 100644
index 000000000000..675a8cf44283
--- /dev/null
+++ b/audio/calf/files/patch-configure.ac
@@ -0,0 +1,20 @@
+--- configure.ac.orig 2015-03-29 13:15:36 UTC
++++ configure.ac
+@@ -5,7 +5,7 @@ AC_PREREQ(2.63)
+ AC_INIT([calf],[0.0.60],[wdev@foltman.com])
+ AC_CONFIG_SRCDIR([config.h.in])
+ AC_CONFIG_HEADER([config.h])
+-LT_INIT([dlopen])
++LT_INIT([dlopen disable-static])
+ LT_LANG([C++])
+
+ AM_INIT_AUTOMAKE(1.8)
+@@ -153,7 +153,7 @@ if test "$set_enable_debug" = "yes"; the
+ CXXFLAGS="$CXXFLAGS -O0 -g -Wall"
+ else
+ # TODO: remove -finline options if clang is used
+- CXXFLAGS="$CXXFLAGS -O3 -finline-functions -finline-functions-called-once -Wall"
++ CXXFLAGS="$CXXFLAGS -Wall"
+ fi
+
+ if test "$set_enable_sse" = "yes"; then
diff --git a/audio/calf/files/patch-src-Makefile.am b/audio/calf/files/patch-src-Makefile.am
new file mode 100644
index 000000000000..963bdf37efdb
--- /dev/null
+++ b/audio/calf/files/patch-src-Makefile.am
@@ -0,0 +1,108 @@
+--- src/Makefile.am.orig 2015-01-24 18:21:15 UTC
++++ src/Makefile.am
+@@ -5,14 +5,14 @@ SUBDIRS = calf
+ lv2dir = $(with_lv2_dir)/calf.lv2
+
+ bin_PROGRAMS =
+-noinst_LTLIBRARIES =
++noinst_LTLIBRARIES = libcalf.la
+
+ noinst_PROGRAMS = calfbenchmark
+-pkglib_LTLIBRARIES = calf.la
++lv2_LTLIBRARIES = calf.la
+
+ AM_CPPFLAGS = -I$(top_srcdir) -I$(srcdir)
+ # TODO: Remove -finline flags is clang is used
+-AM_CXXFLAGS = -ffast-math -finline-limit=80 $(FLUIDSYNTH_DEPS_CFLAGS) $(LV2_DEPS_CFLAGS)
++AM_CXXFLAGS = -ffast-math $(FLUIDSYNTH_DEPS_CFLAGS) $(LV2_DEPS_CFLAGS)
+
+ if USE_GUI
+ AM_CXXFLAGS += $(GUI_DEPS_CFLAGS)
+@@ -22,7 +22,7 @@ AM_CXXFLAGS += $(JACK_DEPS_CFLAGS)
+ noinst_LTLIBRARIES += libcalfgui.la
+ bin_PROGRAMS += calfjackhost
+ calfjackhost_SOURCES = gtk_session_env.cpp host_session.cpp jack_client.cpp jackhost.cpp gtk_main_win.cpp connector.cpp session_mgr.cpp
+-calfjackhost_LDADD = libcalfgui.la calf.la $(JACK_DEPS_LIBS) $(GUI_DEPS_LIBS) $(FLUIDSYNTH_DEPS_LIBS)
++calfjackhost_LDADD = libcalfgui.la libcalf.la $(JACK_DEPS_LIBS) $(GUI_DEPS_LIBS) $(FLUIDSYNTH_DEPS_LIBS)
+ if USE_LASH
+ AM_CXXFLAGS += $(LASH_DEPS_CFLAGS)
+ calfjackhost_LDADD += $(LASH_DEPS_LIBS)
+@@ -32,43 +32,43 @@ endif
+ AM_CXXFLAGS += $(GLIB_DEPS_CFLAGS)
+ noinst_PROGRAMS += calfmakerdf
+ calfmakerdf_SOURCES = makerdf.cpp
+-calfmakerdf_LDADD = calf.la
++calfmakerdf_LDADD = libcalf.la
+
+ calfbenchmark_SOURCES = benchmark.cpp
+-calfbenchmark_LDADD = calf.la
++calfbenchmark_LDADD = libcalf.la
+
+-calf_la_SOURCES = audio_fx.cpp analyzer.cpp metadata.cpp modules_tools.cpp modules_delay.cpp modules_comp.cpp modules_limit.cpp modules_dist.cpp modules_filter.cpp modules_mod.cpp fluidsynth.cpp giface.cpp monosynth.cpp organ.cpp osctl.cpp plugin.cpp preset.cpp synth.cpp utils.cpp wavetable.cpp modmatrix.cpp
+-calf_la_LIBADD = $(FLUIDSYNTH_DEPS_LIBS) $(GLIB_DEPS_LIBS)
++libcalf_la_SOURCES = audio_fx.cpp analyzer.cpp metadata.cpp modules_tools.cpp modules_delay.cpp modules_comp.cpp modules_limit.cpp modules_dist.cpp modules_filter.cpp modules_mod.cpp fluidsynth.cpp giface.cpp monosynth.cpp organ.cpp osctl.cpp plugin.cpp preset.cpp synth.cpp utils.cpp wavetable.cpp modmatrix.cpp
++libcalf_la_LIBADD = $(FLUIDSYNTH_DEPS_LIBS) $(GLIB_DEPS_LIBS) -lexpat
++calf_la_SOURCES = $(libcalf_la_SOURCES)
++calf_la_LIBADD = $(libcalf_la_LIBADD)
+ if USE_DEBUG
+-calf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
++calf_la_LDFLAGS = -avoid-version -module
+ else
+-calf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static -export-symbols-regex "lv2_descriptor"
++calf_la_LDFLAGS = -avoid-version -module -export-symbols-regex "lv2_descriptor"
+ endif
+
+ if USE_LV2_GUI
+
+ # Version WITH out-of-process GUI - links GTK+, UI controls etc.
+
+-noinst_LTLIBRARIES += calflv2gui.la
++lv2_LTLIBRARIES += calflv2gui.la
+
+ calflv2gui_la_SOURCES = gui.cpp gui_config.cpp gui_controls.cpp ctl_curve.cpp ctl_keyboard.cpp ctl_knob.cpp ctl_led.cpp ctl_tube.cpp ctl_vumeter.cpp custom_ctl.cpp metadata.cpp giface.cpp plugin_gui_window.cpp preset.cpp preset_gui.cpp lv2gui.cpp osctl.cpp utils.cpp ctl_linegraph.cpp
++calflv2gui_la_LIBADD = -lexpat $(GUI_DEPS_LIBS)
+
+ if USE_DEBUG
+-calflv2gui_la_LDFLAGS = -rpath $(lv2dir) -avoid-version -module -lexpat $(GUI_DEPS_LIBS) -disable-static
++calflv2gui_la_LDFLAGS = -avoid-version -module
+ else
+-calflv2gui_la_LDFLAGS = -rpath $(lv2dir) -avoid-version -module -lexpat -export-symbols-regex "lv2ui_descriptor" $(GUI_DEPS_LIBS) -disable-static
++calflv2gui_la_LDFLAGS = -avoid-version -module -export-symbols-regex "lv2ui_descriptor"
+ endif
+
+ endif
+
+ if USE_GUI
+ libcalfgui_la_SOURCES = ctl_curve.cpp ctl_keyboard.cpp ctl_knob.cpp ctl_led.cpp ctl_tube.cpp ctl_vumeter.cpp custom_ctl.cpp gui.cpp gui_config.cpp gui_controls.cpp osctl.cpp plugin_gui_window.cpp preset_gui.cpp utils.cpp ctl_linegraph.cpp
+-libcalfgui_la_LDFLAGS = -static -disable-shared -lexpat
++libcalfgui_la_LIBADD = -lexpat
+ endif
+
+-clean-local:
+- $(RM) -f calfjackhost *~
+-
+ install-data-hook:
+ install -d -m 755 $(DESTDIR)$(pkgdatadir)
+ install -c -m 644 $(top_srcdir)/presets.xml $(DESTDIR)$(pkgdatadir)
+@@ -76,11 +76,6 @@ if USE_GUI
+ install -c -m 644 $(top_srcdir)/calf-gui.xml $(DESTDIR)$(pkgdatadir)
+ endif
+ if USE_LV2
+- install -d -m 755 $(DESTDIR)$(lv2dir)
+- ln -sf $(pkglibdir)/calf.so $(DESTDIR)$(lv2dir)/calf.so
+-if USE_LV2_GUI
+- install -c -m 755 $(top_builddir)/src/.libs/calflv2gui.so $(DESTDIR)$(lv2dir)/calflv2gui.so
+-endif
+ rm -f $(DESTDIR)$(lv2dir)/*.ttl
+ $(top_builddir)/src/calfmakerdf -m ttl -p $(DESTDIR)$(lv2dir)/ -d $(DESTDIR)$(pkgdatadir)/
+ if USE_SORDI
+@@ -91,9 +86,6 @@ endif
+ #remove calf.so, calf.rdf and - if empty - ladspa dir in usr/share
+ uninstall-hook:
+ if USE_LV2
+-if USE_LV2_GUI
+- rm -f $(DESTDIR)$(lv2dir)/calflv2gui.so
+-endif
+ rm -f $(DESTDIR)$(lv2dir)/calf.so
+ rm -f $(DESTDIR)$(lv2dir)/*.ttl
+ rmdir -p $(DESTDIR)$(lv2dir) || true
diff --git a/audio/calf/files/patch-src-giface.cpp b/audio/calf/files/patch-src-giface.cpp
new file mode 100644
index 000000000000..eecf206026f8
--- /dev/null
+++ b/audio/calf/files/patch-src-giface.cpp
@@ -0,0 +1,11 @@
+--- src/giface.cpp.orig 2015-01-24 17:21:09 UTC
++++ src/giface.cpp
+@@ -173,7 +173,7 @@ std::string human_readable(float value,
+ }
+ double val = abs(value);
+ int place = (int)(log(val) / log(base));
+- double num = val / pow(base, place);
++ double num = val / pow((double)base, place);
+ sprintf(buf, format, (float)((value > 0) - (value < 0)) * num, suf[place]);
+ return string(buf);
+ }
diff --git a/audio/calf/files/patch-src-monosynth.cpp b/audio/calf/files/patch-src-monosynth.cpp
new file mode 100644
index 000000000000..1c949a8fbef1
--- /dev/null
+++ b/audio/calf/files/patch-src-monosynth.cpp
@@ -0,0 +1,11 @@
+--- src/monosynth.cpp.orig 2015-01-10 10:25:16 UTC
++++ src/monosynth.cpp
+@@ -309,7 +309,7 @@ void monosynth_audio_module::calculate_b
+ {
+ float freq = fabs(*params[par_o2unisonfrq] / muls[7]);
+ if (moddest[moddest_o2unisondetune] != 0)
+- freq *= pow(2.0, moddest[moddest_o2unisondetune]);
++ freq *= pow(2.0, (double)moddest[moddest_o2unisondetune]);
+ unison_osc.set_freq(freq, srate);
+ last_unison_scale = 1.0 / (1.0 + 2 * last_unison);
+ unison_scale = 1.0 / (1.0 + 2 * unison);