aboutsummaryrefslogtreecommitdiffstats
path: root/audio/carla
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /audio/carla
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadfreebsd-ports-gnome-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
freebsd-ports-gnome-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.zst
freebsd-ports-gnome-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'audio/carla')
-rw-r--r--audio/carla/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/carla/Makefile b/audio/carla/Makefile
index 7529333c9110..f29c63997c76 100644
--- a/audio/carla/Makefile
+++ b/audio/carla/Makefile
@@ -18,12 +18,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyliblo>0:audio/py-pyliblo@${PY_FLAVOR}
CONFLICTS_BUILD= rtaudio-* rtmidi-*
USES= compiler:c++11-lib desktop-file-utils gmake localbase \
- pkgconfig pyqt:5 python:3.4+ shared-mime-info shebangfix tar:bz2
+ pkgconfig pyqt:5 python:3.4+ qt:5 shared-mime-info shebangfix tar:bz2
USE_GITHUB= yes
GH_ACCOUNT= falkTX
USE_PYQT= core_run gui_run sip svg_run widgets_run xml_build # "sip" should be "sip_build", but "import PyQt5.QtCore" wants "sip". See bug#225040
USE_GNOME= gtk20 gtk30
-USE_QT5= core gui widgets buildtools_build
+USE_QT= core gui widgets buildtools_build
USE_XORG= x11
USE_LDCONFIG= ${PREFIX}/lib/carla
SHEBANG_FILES= data/carla-single source/native-plugins/resources/*