aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ccaudio/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-07-28 19:05:27 +0800
committersobomax <sobomax@FreeBSD.org>2000-07-28 19:05:27 +0800
commit79b55f19e1756864befe7025b145b204b61a226f (patch)
treed698dd32134d1edd149dd2ac5c29bcc50080b872 /audio/ccaudio/Makefile
parent613ae557d711213647fe516c2fe3f56e1a52026d (diff)
downloadfreebsd-ports-gnome-79b55f19e1756864befe7025b145b204b61a226f.tar.gz
freebsd-ports-gnome-79b55f19e1756864befe7025b145b204b61a226f.tar.zst
freebsd-ports-gnome-79b55f19e1756864befe7025b145b204b61a226f.zip
Add ccaudio - a generic C++ class library for audio files and devices.
PR: 20230 Submitted by: David Sugar <dyfet@gnu.org>
Diffstat (limited to 'audio/ccaudio/Makefile')
-rw-r--r--audio/ccaudio/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
new file mode 100644
index 000000000000..aba8b360e2d7
--- /dev/null
+++ b/audio/ccaudio/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ccaudio
+# Date created: 26 July 2000
+# Whom: David Sugar <dyfet@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ccaudio
+PORTVERSION= 0.2.3
+CATEGORIES= audio
+MASTER_SITES= ftp://www.voxilla.org/pub/ccaudio/
+
+MAINTAINER= dyfet@gnu.org
+
+LIB_DEPENDS= ccstd.0:${PORTSDIR}/devel/commoncpp
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \@LT_RELEASE\@||g'
+
+.include <bsd.port.mk>